summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 12:43:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 12:43:15 +0000
commit8c8aef1702992703341af77c46cd5b995c9425a8 (patch)
tree18ed5c7bf2273bf585ae3ea9093a694c95c96712 /app-text/gsview
parentImported from sunrise overlay, 258150 (diff)
downloadgentoo-2-8c8aef1702992703341af77c46cd5b995c9425a8.tar.gz
gentoo-2-8c8aef1702992703341af77c46cd5b995c9425a8.tar.bz2
gentoo-2-8c8aef1702992703341af77c46cd5b995c9425a8.zip
Version Bump, 284197; LDFLAGS respect, 333537
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gsview')
-rw-r--r--app-text/gsview/ChangeLog10
-rw-r--r--app-text/gsview/files/4.9-gentoo.patch31
-rw-r--r--app-text/gsview/gsview-4.9.ebuild62
3 files changed, 101 insertions, 2 deletions
diff --git a/app-text/gsview/ChangeLog b/app-text/gsview/ChangeLog
index 7cb4f934c315..24c80b3761bd 100644
--- a/app-text/gsview/ChangeLog
+++ b/app-text/gsview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/gsview
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/ChangeLog,v 1.31 2009/12/26 19:38:59 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/ChangeLog,v 1.32 2010/10/03 12:43:15 jlec Exp $
+
+*gsview-4.9 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/4.9-gentoo.patch,
+ +gsview-4.9.ebuild:
+ Version Bump, 284197; LDFLAGS respect, 333537
26 Dec 2009; Peter Volkov <pva@gentoo.org> gsview-4.8.ebuild:
virtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only
diff --git a/app-text/gsview/files/4.9-gentoo.patch b/app-text/gsview/files/4.9-gentoo.patch
new file mode 100644
index 000000000000..38ff9bb2fd5c
--- /dev/null
+++ b/app-text/gsview/files/4.9-gentoo.patch
@@ -0,0 +1,31 @@
+diff --git a/srcunx/unx.mak b/srcunx/unx.mak
+index 3bd1769..ee86618 100644
+--- a/srcunx/unx.mak
++++ b/srcunx/unx.mak
+@@ -39,7 +39,7 @@ GSVIEW_DOCPATH=$(GSVIEW_BASE)/share/doc
+ GSVIEW_ETCPATH=$(prefix)/etc
+
+ MAKE=make
+-CC=gcc
++CC ?= gcc
+ OBJ=o
+ INSTALL=install -m 644
+ INSTALL_EXE=install -m 755
+@@ -77,7 +77,7 @@ PLINK=-lpthread -lrt
+
+ # Other possible options are -Wtraditional
+ # Compiler flags for C and C++ files.
+-CFLAGS=-O -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-prototypes -fno-builtin -fno-common -Wcast-qual -Wwrite-strings $(CDEBUG) -DX11 -DUNIX -DNONAG $(RPM_OPT_FLAGS) `gtk-config --cflags` $(XINCLUDE) $(PFLAGS)
++CFLAGS += $(CDEBUG) -DX11 -DUNIX -DNONAG $(RPM_OPT_FLAGS) `gtk-config --cflags` $(XINCLUDE) $(PFLAGS)
+
+ # Linker flags
+ LFLAGS=$(LDEBUG) $(PLINK) `gtk-config --libs`
+@@ -155,7 +155,7 @@ all: $(BD)gsview$(EXE) html
+ GSVIEW_DOCDIR=$(GSVIEW_DOCPATH)/gsview-$(GSVIEW_DOT_VERSION)
+
+ $(BD)gsview$(EXE): $(OBJS)
+- $(COMP) $(CFLAGS) $(FO)$(BD)gsview$(EXE) $(OBJS) $(LFLAGS)
++ $(COMP) $(CFLAGS) $(LDFLAGS) $(FO)$(BD)gsview$(EXE) $(OBJS) $(LFLAGS)
+
+ install: all
+ -mkdir -p $(GSVIEW_BASE)
diff --git a/app-text/gsview/gsview-4.9.ebuild b/app-text/gsview/gsview-4.9.ebuild
new file mode 100644
index 000000000000..2d9024fbc2eb
--- /dev/null
+++ b/app-text/gsview/gsview-4.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/gsview-4.9.ebuild,v 1.1 2010/10/03 12:43:15 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+MY_PV="${PV/.}"
+
+DESCRIPTION="gsView PostScript and PDF viewer"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/gsv${MY_PV}src.zip"
+
+IUSE="doc"
+SLOT="0"
+LICENSE="Aladdin"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ app-text/epstool
+ app-text/pstotext
+ app-text/ghostscript-gpl"
+DEPEND="app-arch/unzip
+ =x11-libs/gtk+-1.2*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ ln -sf srcunx/unx.mak Makefile
+
+ ## respect CFLAGS
+ sed -i -e "s:^CFLAGS=-O :CFLAGS=${CFLAGS} :g" Makefile
+ sed -i -e "s:GSVIEW_DOCPATH:\"${EPREFIX}/usr/share/doc/${PF}/html/\":" srcunx/gvx.c
+
+ ## run Makefile
+ # bug #283165
+ emake -j1 || die "Error compiling files."
+}
+
+src_install() {
+ dobin bin/gsview
+
+ doman srcunx/gsview.1
+
+ dodoc gsview.css cdorder.txt regorder.txt
+
+ if use doc
+ then
+ dobin ${FILESDIR}/gsview-help
+ dohtml *.htm bin/*.htm
+ fi
+
+ insinto /etc/gsview
+ doins src/printer.ini
+
+ make_desktop_entry gsview Gsview "" "Office" ||
+ die "Couldn't make gsview desktop entry"
+}