summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-12 02:06:40 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-12 02:06:40 +0000
commite63bf0221f127671e15ee1274e1e6746fd3e7bbd (patch)
tree41017fb3532de26ff1b99d603b98100957ec33c6 /app-text/highlight
parentDrop HPPA keywording (bug #382495). (diff)
downloadgentoo-2-e63bf0221f127671e15ee1274e1e6746fd3e7bbd.tar.gz
gentoo-2-e63bf0221f127671e15ee1274e1e6746fd3e7bbd.tar.bz2
gentoo-2-e63bf0221f127671e15ee1274e1e6746fd3e7bbd.zip
Version bump.
(Portage version: 2.2.0_alpha66/cvs/Linux x86_64)
Diffstat (limited to 'app-text/highlight')
-rw-r--r--app-text/highlight/ChangeLog7
-rw-r--r--app-text/highlight/highlight-3.6.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index abd10ceb743b..be6f324bb144 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/highlight
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.44 2011/08/30 02:22:29 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.45 2011/10/12 02:06:40 radhermit Exp $
+
+*highlight-3.6 (12 Oct 2011)
+
+ 12 Oct 2011; Tim Harder <radhermit@gentoo.org> +highlight-3.6.ebuild:
+ Version bump.
30 Aug 2011; Naohiro Aota <naota@gentoo.org> highlight-3.5.ebuild:
Add ~x86-fbsd
diff --git a/app-text/highlight/highlight-3.6.ebuild b/app-text/highlight/highlight-3.6.ebuild
new file mode 100644
index 000000000000..549a05a14fe6
--- /dev/null
+++ b/app-text/highlight/highlight-3.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.6.ebuild,v 1.1 2011/10/12 02:06:40 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs qt4-r2
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de/"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples qt4"
+
+DEPEND="dev-lang/lua
+ dev-libs/boost
+ qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-core:4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ myhlopts=(
+ "CXX=$(tc-getCXX)"
+ "AR=$(tc-getAR)"
+ "LDFLAGS=${LDFLAGS}"
+ "CFLAGS=${CXXFLAGS}"
+ "DESTDIR=${D}"
+ "PREFIX=${EPREFIX}/usr"
+ "LUA_CFLAGS="
+ "HL_CONFIG_DIR=${EPREFIX}/etc/highlight/"
+ "HL_DATA_DIR=${EPREFIX}/usr/share/highlight/"
+ "doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
+ "conf_dir=${EPREFIX}/etc/highlight/"
+ )
+}
+
+src_prepare() {
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+}
+
+src_compile() {
+ emake -f makefile "${myhlopts[@]}"
+ if use qt4 ; then
+ cd src/gui-qt
+ eqmake4 'DEFINES+=DATA_DIR=\\\"'"${EPREFIX}"'/usr/share/${PN}/\\\" CONFIG_DIR=\\\"'"${EPREFIX}"'/etc/${PN}/\\\" DOC_DIR=\\\"'"${EPREFIX}"'/usr/share/doc/${PF}/\\\"'
+ emake
+ fi
+}
+
+src_install() {
+ emake -f makefile "${myhlopts[@]}" install
+ use qt4 && emake -f makefile "${myhlopts[@]}" install-gui
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${ED}"/usr/share/doc/${PF}/examples
+ fi
+}