summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-14 13:20:08 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-14 13:20:08 +0000
commitb2303a1721a055273e87af2041a7c779d784d52a (patch)
treef9059034f3ec31df224a4385e8ff09e2eaae7218 /app-text/hnb/files
parentversion bump and drop RCs (diff)
downloadgentoo-2-b2303a1721a055273e87af2041a7c779d784d52a.tar.gz
gentoo-2-b2303a1721a055273e87af2041a7c779d784d52a.tar.bz2
gentoo-2-b2303a1721a055273e87af2041a7c779d784d52a.zip
Fix grep locale (bug #532552). Fix building against sys-libs/ncurses[tinfo] (bug #457530). Respect AR. Clean up patch.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-text/hnb/files')
-rw-r--r--app-text/hnb/files/hnb-1.9.18-flags.patch77
-rw-r--r--app-text/hnb/files/hnb-1.9.18-include.patch4
2 files changed, 29 insertions, 52 deletions
diff --git a/app-text/hnb/files/hnb-1.9.18-flags.patch b/app-text/hnb/files/hnb-1.9.18-flags.patch
index 325ec1187103..4111b7078d70 100644
--- a/app-text/hnb/files/hnb-1.9.18-flags.patch
+++ b/app-text/hnb/files/hnb-1.9.18-flags.patch
@@ -1,5 +1,5 @@
---- ./hnb-1.9.18/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
-+++ ./hnb-1.9.18/Makefile 2009-10-23 14:23:16.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,19 +1,19 @@
src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
@@ -24,43 +24,18 @@
echo -n "\"">src/hnbrc.inc
cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
echo "\"">>src/hnbrc.inc
---- ./hnb-1.9.18/hnb-1.9.18/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
-+++ ./hnb-1.9.18/hnb-1.9.18/Makefile 2009-10-23 14:23:16.000000000 +0200
-@@ -1,19 +1,19 @@
-
- src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
-- (cd src;make)
-+ (cd src;$(MAKE))
- install: src/hnb
- install -D src/hnb /usr/local/bin/hnb
- install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
- clean:
-- (cd src;make clean)
-- (cd util;make clean)
-+ (cd src;$(MAKE) clean)
-+ (cd util;$(MAKE) clean)
- rm -f *~
-
- rcupdate: updaterc
- updaterc: src/hnbrc.inc
-
- src/hnbrc.inc: doc/hnbrc
-- (cd util;make)
-+ (cd util;$(MAKE))
- echo -n "\"">src/hnbrc.inc
- cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
- echo "\"">>src/hnbrc.inc
---- ./hnb-1.9.18/src/Makefile.orig 2003-08-27 04:50:58.000000000 +0200
-+++ ./hnb-1.9.18/src/Makefile 2009-10-23 14:23:16.000000000 +0200
+--- a/src/Makefile
++++ b/src/Makefile
@@ -1,5 +1,6 @@
- LIBS=-lncurses libcli/libcli.a
+-LIBS=-lncurses libcli/libcli.a
-CFLAGS=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall -pedantic -g
++LIBS=$(shell ${PKG_CONFIG} --libs ncurses) libcli/libcli.a
+CFLAGS+=-Wall -pedantic
+CPPFLAGS+=-I.. -Ilibcli -DHAVE_CONFIG_H
CFILES=$(wildcard *.c)
OBJS=$(patsubst %.c,%.o,$(CFILES))
-@@ -8,12 +9,12 @@
+@@ -8,22 +9,22 @@
$(CC) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
hnb: libcli/libcli.a Makefile $(OBJS) init_subsystems.c *.h *.inc
@@ -72,11 +47,16 @@
+ (cd libcli;$(MAKE) libcli.a)
libcli/libcli_p.a: libcli/*.c
- (cd libcli;make libcli_p.a)
+-init_subsystems.c: *.c
+ (cd libcli;$(MAKE) libcli_p.a)
- init_subsystems.c: *.c
++init_subsystems.c: $(CFILES)
echo "/* this file is autogenerated, do not edit */">init_subsystems.c
- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
-@@ -23,7 +24,7 @@
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
+ echo "">>init_subsystems.c
+ echo "void init_subsystems(){">>init_subsystems.c
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
echo "}">>init_subsystems.c
clean:
rm -f xml_debug hnb $(OBJS) *~ cli_*.inc
@@ -85,22 +65,19 @@
hnb_p: *.c libcli/libcli_p.a init_subsystems.c
$(CC) -o hnb_p *.c -pg -lncurses_p libcli/libcli_p.a -I.. -Ilibcli -DHAVE_CONFIG_H
---- ./hnb-1.9.18/src/libcli/Makefile.orig 2003-08-27 04:50:59.000000000 +0200
-+++ ./hnb-1.9.18/src/libcli/Makefile 2009-10-23 14:25:37.000000000 +0200
-@@ -1,5 +1,3 @@
--CFLAGS = -Wall
--
- OBJS = cli.o cli_history.o cli_tokenize.o
-
- all: libcli.a libcli.so test-static test-shared
-@@ -9,8 +7,8 @@
+--- a/src/libcli/Makefile
++++ b/src/libcli/Makefile
+@@ -7,11 +7,11 @@
+ clean:
+ rm -f *.o *.a *.so test-s* *~
libcli.a: $(OBJS)
- ar rc libcli.a cli*.o
+- ar rc libcli.a cli*.o
++ $(AR) rc libcli.a cli*.o
libcli_p.a:
-- $(CC) -pg -c cli.c
-- $(CC) -pg -c cli_history.c
-+ $(CC) -pg -c cli.c $(CFLAGS)
-+ $(CC) -pg -c cli_history.c $(CFLAGS)
- ar rcs libcli_p.a cli*.o
+ $(CC) -pg -c cli.c
+ $(CC) -pg -c cli_history.c
+- ar rcs libcli_p.a cli*.o
++ $(AR) rcs libcli_p.a cli*.o
libcli.so: $(OBJS)
$(CC) -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
+ test-static: test.o libcli.a
diff --git a/app-text/hnb/files/hnb-1.9.18-include.patch b/app-text/hnb/files/hnb-1.9.18-include.patch
index 6c00386331d4..9ee57a351d51 100644
--- a/app-text/hnb/files/hnb-1.9.18-include.patch
+++ b/app-text/hnb/files/hnb-1.9.18-include.patch
@@ -1,5 +1,5 @@
---- hnb-1.9.18/src/expanded.c.orig 2003-08-27 04:50:59.000000000 +0200
-+++ hnb-1.9.18/src/expanded.c 2009-10-23 14:40:16.000000000 +0200
+--- a/src/expanded.c
++++ b/src/expanded.c
@@ -18,9 +18,9 @@
* Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*/