summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-12 14:16:27 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-12 14:16:27 +0000
commitc49e9b64e35222eb7662866825fffc0e1be2f2d9 (patch)
tree9641af60ea822b60fe20a7195e0dba5a8d10e98b /app-text/ispell/ispell-3.2.06-r6.ebuild
parentblah, forgot to check this in (diff)
downloadgentoo-2-c49e9b64e35222eb7662866825fffc0e1be2f2d9.tar.gz
gentoo-2-c49e9b64e35222eb7662866825fffc0e1be2f2d9.tar.bz2
gentoo-2-c49e9b64e35222eb7662866825fffc0e1be2f2d9.zip
blah, forgot to check this in
Diffstat (limited to 'app-text/ispell/ispell-3.2.06-r6.ebuild')
-rw-r--r--app-text/ispell/ispell-3.2.06-r6.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/ispell/ispell-3.2.06-r6.ebuild b/app-text/ispell/ispell-3.2.06-r6.ebuild
new file mode 100644
index 000000000000..5204a9bf5ac4
--- /dev/null
+++ b/app-text/ispell/ispell-3.2.06-r6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.2.06-r6.ebuild,v 1.1 2003/09/12 14:16:25 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
+ mirror://gentoo/${PF}-gentoo.diff.bz2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~mips ~hppa"
+
+DEPEND="sys-apps/sed
+ dev-util/byacc
+ sys-apps/miscfiles
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ make config.sh || die
+
+ #Fix config.sh to install to ${D}
+ cp -p config.sh config.sh.orig
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN4DIR='\)\(.*\):\1${D}\2:" \
+ < config.sh > config.sh.install
+
+ make || die
+}
+
+src_install() {
+ cp -p config.sh.install config.sh
+
+ #Need to create the directories to install into
+ #before 'make install'. Build environment **doesn't**
+ #check for existence and create if not already there.
+ dodir /usr/bin /usr/lib/ispell /usr/share/info \
+ /usr/share/man/man1 /usr/share/man/man5
+
+ make \
+ install || die "Installation Failed"
+
+ rmdir ${D}/usr/share/man/man5
+ rmdir ${D}/usr/share/info
+
+ dodoc Contributors README WISHES
+
+ dosed ${D}/usr/share/man/man1/ispell.1
+}