summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-06-01 03:08:56 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-06-01 03:08:56 +0000
commitf7e4b004cb7ebbecbef5837dbe9171dec474ad7b (patch)
tree0488e0460655fd238d53338639a52138ad2a72cd /app-text/kding
parentFix net.lo test in upgrade path as pointed out by compguy284 #224425. (diff)
downloadgentoo-2-f7e4b004cb7ebbecbef5837dbe9171dec474ad7b.tar.gz
gentoo-2-f7e4b004cb7ebbecbef5837dbe9171dec474ad7b.tar.bz2
gentoo-2-f7e4b004cb7ebbecbef5837dbe9171dec474ad7b.zip
Version bump.
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-text/kding')
-rw-r--r--app-text/kding/ChangeLog9
-rw-r--r--app-text/kding/kding-0.4.3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-text/kding/ChangeLog b/app-text/kding/ChangeLog
index 657c96729158..ef38e02b057b 100644
--- a/app-text/kding/ChangeLog
+++ b/app-text/kding/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/kding
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kding/ChangeLog,v 1.4 2007/12/30 16:32:26 maekke Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kding/ChangeLog,v 1.5 2008/06/01 03:08:56 tgurr Exp $
+
+*kding-0.4.3 (01 Jun 2008)
+
+ 01 Jun 2008; Timo Gurr <tgurr@gentoo.org> +kding-0.4.3.ebuild:
+ Version bump.
30 Dec 2007; Markus Meier <maekke@gentoo.org> kding-0.4.1.ebuild:
x86 stable, bug #203342
diff --git a/app-text/kding/kding-0.4.3.ebuild b/app-text/kding/kding-0.4.3.ebuild
new file mode 100644
index 000000000000..30cf07b9266c
--- /dev/null
+++ b/app-text/kding/kding-0.4.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kding/kding-0.4.3.ebuild,v 1.1 2008/06/01 03:08:56 tgurr Exp $
+
+inherit eutils kde
+
+DESCRIPTION="KDing is a KDE port of Ding, a dictionary lookup program."
+HOMEPAGE="http://www.rexi.org/software/kding/"
+SRC_URI="http://www.rexi.org/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+need-kde 3.5
+
+LANGS="de"
+LANGS_DOC="de en"
+
+for X in ${LANGS} ${LANGS_DOC} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ cd "${S}"
+ elibtoolize
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${P}/po"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}.po"
+ done
+ sed -i -e "s:POFILES =.*:POFILES = ${MAKE_LANGS}:" Makefile.am
+
+ MAKE_LANGS=""
+ cd "${WORKDIR}/${P}/doc"
+ for X in ${LANGS_DOC} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ sed -i -e "s:SUBDIRS =.*:SUBDIRS = ${MAKE_LANGS}:" Makefile.am
+ rm -f "${S}"/configure
+}