summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 09:31:53 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 09:31:53 +0000
commit815981374e02e3b307862b7b8b88feac0af72b5d (patch)
tree7957f0cb0408a1b88ac0ffab004598441289330e /app-text/libspectre
parentVersion bump, drop old. (diff)
downloadgentoo-2-815981374e02e3b307862b7b8b88feac0af72b5d.tar.gz
gentoo-2-815981374e02e3b307862b7b8b88feac0af72b5d.tar.bz2
gentoo-2-815981374e02e3b307862b7b8b88feac0af72b5d.zip
Version bump.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/ChangeLog8
-rw-r--r--app-text/libspectre/libspectre-0.2.7.ebuild51
2 files changed, 57 insertions, 2 deletions
diff --git a/app-text/libspectre/ChangeLog b/app-text/libspectre/ChangeLog
index 8f1ddc6d45f3..f44c6a02e971 100644
--- a/app-text/libspectre/ChangeLog
+++ b/app-text/libspectre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libspectre
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/ChangeLog,v 1.57 2012/05/09 15:11:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/ChangeLog,v 1.58 2012/09/15 09:31:53 pacho Exp $
+
+*libspectre-0.2.7 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org> +libspectre-0.2.7.ebuild:
+ Version bump.
09 May 2012; Alexis Ballier <aballier@gentoo.org> libspectre-0.2.6.ebuild:
keyword ~amd64-fbsd
@@ -208,4 +213,3 @@
06 Feb 2008; Bo Ørsted Andresen <zlin@gentoo.org> +metadata.xml,
+libspectre-0.2.0.ebuild:
Initial import of libspectre for bug #208617.
-
diff --git a/app-text/libspectre/libspectre-0.2.7.ebuild b/app-text/libspectre/libspectre-0.2.7.ebuild
new file mode 100644
index 000000000000..a2c41af4eb72
--- /dev/null
+++ b/app-text/libspectre/libspectre-0.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/libspectre-0.2.7.ebuild,v 1.1 2012/09/15 09:31:52 pacho Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A library for rendering Postscript documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libspectre"
+SRC_URI="http://libspectre.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug doc static-libs"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.62"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# does not actually test anything, see bug 362557
+RESTRICT="test"
+
+DOCS="NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
+ eautoreconf # need new libtool for interix
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug asserts) \
+ $(use_enable debug checks) \
+ $(use_enable static-libs static) \
+ --disable-test
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ find "${D}" -name '*.la' -exec rm -f {} +
+}