summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-04-19 09:26:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-04-19 09:26:19 +0000
commit8413ae4c3f7b2da14cb9adb3a09ecd56913ef3f8 (patch)
treed1636f5afd6b9916232c9b95e0fc80f83b32f640 /app-text/libwpg
parentVersion bump to the latest. Update license. (diff)
downloadgentoo-2-8413ae4c3f7b2da14cb9adb3a09ecd56913ef3f8.tar.gz
gentoo-2-8413ae4c3f7b2da14cb9adb3a09ecd56913ef3f8.tar.bz2
gentoo-2-8413ae4c3f7b2da14cb9adb3a09ecd56913ef3f8.zip
Version bump to latest.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text/libwpg')
-rw-r--r--app-text/libwpg/ChangeLog10
-rw-r--r--app-text/libwpg/libwpg-0.2.2.ebuild49
2 files changed, 56 insertions, 3 deletions
diff --git a/app-text/libwpg/ChangeLog b/app-text/libwpg/ChangeLog
index a17ac07512a6..5561f0e6d642 100644
--- a/app-text/libwpg/ChangeLog
+++ b/app-text/libwpg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwpg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpg/ChangeLog,v 1.16 2012/08/05 21:02:39 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpg/ChangeLog,v 1.17 2013/04/19 09:26:19 scarabeus Exp $
+
+*libwpg-0.2.2 (19 Apr 2013)
+
+ 19 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> +libwpg-0.2.2.ebuild:
+ Version bump to latest.
05 Aug 2012; Anthony G. Basile <blueness@gentoo.org> libwpg-0.2.1.ebuild:
Keyword ~arm
@@ -128,4 +133,3 @@
01 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +libwpg-0.1.3.ebuild,
+metadata.xml:
Initial commit. Required for koffice-2
-
diff --git a/app-text/libwpg/libwpg-0.2.2.ebuild b/app-text/libwpg/libwpg-0.2.2.ebuild
new file mode 100644
index 000000000000..7cc418dd50d7
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpg/libwpg-0.2.2.ebuild,v 1.1 2013/04/19 09:26:19 scarabeus Exp $
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND="app-text/libwpd:0.9[tools]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.1.3-r1"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --program-suffix=-${SLOT} \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]" fi
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}