summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-05-31 12:14:01 +0000
committerTom William Payne <twp@gentoo.org>2004-05-31 12:14:01 +0000
commitbc2b36af2c6fc2c499cb72c78da65bd3bf127ad0 (patch)
tree1c96b9efab146c5a1eafeeaef6603ef647500b34 /app-text/man2html/man2html-1.5l-r2.ebuild
parentapp-text/man2html blocking on bug # 52544 (diff)
downloadgentoo-2-bc2b36af2c6fc2c499cb72c78da65bd3bf127ad0.tar.gz
gentoo-2-bc2b36af2c6fc2c499cb72c78da65bd3bf127ad0.tar.bz2
gentoo-2-bc2b36af2c6fc2c499cb72c78da65bd3bf127ad0.zip
Patch to use webapp eclass, thanks Rob Kruus. Bug # 52119, masked in package.mask pending bug # 52544.
Diffstat (limited to 'app-text/man2html/man2html-1.5l-r2.ebuild')
-rw-r--r--app-text/man2html/man2html-1.5l-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/man2html/man2html-1.5l-r2.ebuild b/app-text/man2html/man2html-1.5l-r2.ebuild
new file mode 100644
index 000000000000..6701100d6dbe
--- /dev/null
+++ b/app-text/man2html/man2html-1.5l-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/man2html-1.5l-r2.ebuild,v 1.1 2004/05/31 12:14:01 twp Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Convert manual pages to HTML"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+SRC_URI="mirror://kernel/linux/utils/man/man-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~sparc ~x86 ~ia64"
+
+DEPEND="app-misc/glimpse
+ sys-apps/gawk
+ sys-apps/man"
+
+S=${WORKDIR}/man-${PV}
+
+pkg_setup() {
+ webapp_pkg_setup
+ einfo "Installing into ${MY_HOSTROOTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/mansearch-gentoo.patch
+ epatch ${FILESDIR}/manwhatis-gentoo.patch
+ epatch ${FILESDIR}/mansec.patch
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/htdocs/:/var/www/localhost/:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-bin/:/var/www/localhost/cgi-bin/man:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-aux/man:/var/www/localhost/cgi-aux/man:g"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd man2html
+ exeinto ${MY_HOSTROOTDIR}/cgi-bin/man
+ doexe scripts/cgi-bin/man/*
+ insinto ${MY_HOSTROOTDIR}/cgi-aux/man
+ doins scripts/cgi-aux/man/*
+ insinto /var/man2html
+ newins glimpse_filters .glimpse_filters
+ fperms 1777 /var/man2html
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/man2html.cron
+
+ webapp_src_install
+}