summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2005-06-22 03:45:09 +0000
committerPaul Varner <fuzzyray@gentoo.org>2005-06-22 03:45:09 +0000
commit31fd7178d408c0ad421a1b487c271e1903c19532 (patch)
treecde5b2de81e30dbf7a49e4035dfe86fc88c04ee8 /app-text/manedit/manedit-0.6.1.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-31fd7178d408c0ad421a1b487c271e1903c19532.tar.gz
gentoo-2-31fd7178d408c0ad421a1b487c271e1903c19532.tar.bz2
gentoo-2-31fd7178d408c0ad421a1b487c271e1903c19532.zip
Revision bump to fix Bug 90407
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text/manedit/manedit-0.6.1.ebuild')
-rw-r--r--app-text/manedit/manedit-0.6.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/manedit/manedit-0.6.1.ebuild b/app-text/manedit/manedit-0.6.1.ebuild
new file mode 100644
index 000000000000..d6408797af4d
--- /dev/null
+++ b/app-text/manedit/manedit-0.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/manedit-0.6.1.ebuild,v 1.1 2005/06/22 03:45:09 fuzzyray Exp $
+
+DESCRIPTION="Man page editor using XML tags"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+HOMEPAGE="http://wolfpack.twu.net/ManEdit/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/x11
+ =x11-libs/gtk+-1*
+ sys-libs/zlib
+ app-arch/bzip2"
+
+src_compile() {
+ # It autodetects x86 processors and adds the -march option itself
+ # but we don't actually want that.
+ env CFLAGS="${CFLAGS}" ./configure Linux \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ --enable=bzip2 \
+ --enable=zlib \
+ --disable="arch-i486" \
+ --disable="arch-i586" \
+ --disable="arch-i686" \
+ --disable="arch-pentiumpro" || die "Bad Configure"
+ emake || die "Compile Error"
+}
+
+src_install() {
+ # fix strip error (tries to strip a shell script)
+ cp manedit/Makefile.install.UNIX{,.orig}
+ sed -e '/INST.*FLAGS.*-s$/s:-s::' \
+ manedit/Makefile.install.UNIX.orig > manedit/Makefile.install.UNIX
+
+ # set man dir too or FHS is violated (/usr/man)
+ make \
+ PREFIX=${D}/usr \
+ MAN_DIR=${D}/usr/share/man/man1 \
+ ICONS_DIR=${D}/usr/share/pixmaps \
+ install || die "make install failed."
+
+ dodoc AUTHORS LICENSE README
+}