summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-12 16:44:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-12 16:44:47 +0000
commit9ea0858497168821f0582a1c47b7bddc1e124b4d (patch)
tree55c24330a94ca883463295add6c516ea408895aa /app-text/namazu
parentAdded USE=perl to install perl bindings (diff)
downloadgentoo-2-9ea0858497168821f0582a1c47b7bddc1e124b4d.tar.gz
gentoo-2-9ea0858497168821f0582a1c47b7bddc1e124b4d.tar.bz2
gentoo-2-9ea0858497168821f0582a1c47b7bddc1e124b4d.zip
Version bumped. Replaced chasen, cjk, and kakasi to linguas_ja.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-text/namazu')
-rw-r--r--app-text/namazu/ChangeLog8
-rw-r--r--app-text/namazu/files/namazu-2.0.19-gentoo.patch29
-rw-r--r--app-text/namazu/namazu-2.0.19.ebuild78
3 files changed, 114 insertions, 1 deletions
diff --git a/app-text/namazu/ChangeLog b/app-text/namazu/ChangeLog
index a04e584e1158..939767dd4f36 100644
--- a/app-text/namazu/ChangeLog
+++ b/app-text/namazu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/namazu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.31 2009/01/19 01:13:03 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.32 2009/03/12 16:44:46 matsuu Exp $
+
+*namazu-2.0.19 (12 Mar 2009)
+
+ 12 Mar 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/namazu-2.0.19-gentoo.patch, +namazu-2.0.19.ebuild:
+ Version bumped. Replaced chasen, cjk, and kakasi USE flags to linguas_ja.
19 Jan 2009; Tiago Cunha <tcunha@gentoo.org> namazu-2.0.18.ebuild:
keyworded ~arch for sparc
diff --git a/app-text/namazu/files/namazu-2.0.19-gentoo.patch b/app-text/namazu/files/namazu-2.0.19-gentoo.patch
new file mode 100644
index 000000000000..6d7f649507bd
--- /dev/null
+++ b/app-text/namazu/files/namazu-2.0.19-gentoo.patch
@@ -0,0 +1,29 @@
+diff -Naur namazu-2.0.19.orig/filter/Makefile.am namazu-2.0.19/filter/Makefile.am
+--- namazu-2.0.19.orig/filter/Makefile.am 2008-05-03 02:07:03.000000000 +0900
++++ namazu-2.0.19/filter/Makefile.am 2009-03-13 01:04:20.000000000 +0900
+@@ -51,9 +51,3 @@
+
+ ETAGS_ARGS = $(filter_DATA) --lang=perl
+ TAGS_DEPENDENCIES = $(filter_DATA)
+-
+-# To remove Windows specific files installed by Namazu 2.0 and/or 2.0.1
+-# and old gfilter.pl (Namazu 2.0.7 or earlier).
+-install-data-local:
+- rm -f $(filterdir)/ole*.pl
+- rm -f $(filterdir)/gfilter.pl
+diff -Naur namazu-2.0.19.orig/filter/Makefile.in namazu-2.0.19/filter/Makefile.in
+--- namazu-2.0.19.orig/filter/Makefile.in 2009-03-12 23:24:48.000000000 +0900
++++ namazu-2.0.19/filter/Makefile.in 2009-03-13 01:05:08.000000000 +0900
+@@ -455,12 +455,6 @@
+ uninstall uninstall-am uninstall-filterDATA uninstall-info-am \
+ uninstall-info-recursive uninstall-recursive
+
+-
+-# To remove Windows specific files installed by Namazu 2.0 and/or 2.0.1
+-# and old gfilter.pl (Namazu 2.0.7 or earlier).
+-install-data-local:
+- rm -f $(filterdir)/ole*.pl
+- rm -f $(filterdir)/gfilter.pl
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/app-text/namazu/namazu-2.0.19.ebuild b/app-text/namazu/namazu-2.0.19.ebuild
new file mode 100644
index 000000000000..a5cacd871bf3
--- /dev/null
+++ b/app-text/namazu/namazu-2.0.19.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.19.ebuild,v 1.1 2009/03/12 16:44:46 matsuu Exp $
+
+inherit eutils elisp-common
+
+IUSE="emacs nls tk linguas_ja"
+
+DESCRIPTION="Namazu is a full-text search engine"
+HOMEPAGE="http://www.namazu.org/"
+SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=dev-perl/File-MMagic-1.20
+ emacs? ( virtual/emacs )
+ linguas_ja? (
+ app-i18n/nkf
+ || (
+ dev-perl/Text-Kakasi
+ app-i18n/kakasi
+ app-text/chasen
+ app-text/mecab
+ )
+ )
+ nls? ( sys-devel/gettext )
+ tk? (
+ dev-lang/tk
+ www-client/lynx
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ local myconf
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable tk tknamazu) \
+ ${myconf} || die
+ emake || die
+
+ if use emacs; then
+ cd lisp
+ elisp-compile gnus-nmz-1.el namazu.el || die
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+# rm -rf "${D}"/usr/share/namazu/{doc,etc}
+
+ dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO etc/*.png
+ dohtml -r doc/*
+
+ if use emacs; then
+ elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el* || die
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el || die
+
+ docinto lisp
+ dodoc lisp/ChangeLog*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}