summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-21 04:19:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-21 04:19:52 +0000
commit72875d922397b2e1e53760a6cb0501c2fea2da67 (patch)
treefb5443f21b8e1f1d4386d16d6f04b11c1fa7f4e7 /app-text/opensp/opensp-1.5.2-r3.ebuild
parentVersion bump for 1.4 and 1.6 series. Fix bug #462144 (diff)
downloadgentoo-2-72875d922397b2e1e53760a6cb0501c2fea2da67.tar.gz
gentoo-2-72875d922397b2e1e53760a6cb0501c2fea2da67.tar.bz2
gentoo-2-72875d922397b2e1e53760a6cb0501c2fea2da67.zip
Use prune_libtool_files to remove unnecessary libtool archive (.la) of libosp.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-text/opensp/opensp-1.5.2-r3.ebuild')
-rw-r--r--app-text/opensp/opensp-1.5.2-r3.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/app-text/opensp/opensp-1.5.2-r3.ebuild b/app-text/opensp/opensp-1.5.2-r3.ebuild
index c7eaf53a448c..05c6994bdcf1 100644
--- a/app-text/opensp/opensp-1.5.2-r3.ebuild
+++ b/app-text/opensp/opensp-1.5.2-r3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.2-r3.ebuild,v 1.14 2012/11/16 09:34:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.2-r3.ebuild,v 1.15 2013/03/21 04:19:52 ssuominen Exp $
-EAPI=4
+EAPI=5
inherit eutils flag-o-matic
MY_P=${P/opensp/OpenSP}
+
DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
HOMEPAGE="http://openjade.sourceforge.net/"
SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
@@ -15,7 +16,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc nls static-libs test"
-DEPEND="nls? ( >=sys-devel/gettext-0.14.5 )
+DEPEND="nls? ( sys-devel/gettext )
doc? (
app-text/xmlto
app-text/docbook-xml-dtd:4.1.2
@@ -29,15 +30,13 @@ RDEPEND=""
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5-gcc34.patch
- epatch "${FILESDIR}"/${P}-fix-segfault.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.5-gcc34.patch \
+ "${FILESDIR}"/${P}-fix-segfault.patch
}
src_configure() {
- #
# The following filters are taken from openjade's ebuild. See bug #100828.
- #
-
# Please note! Opts are disabled. If you know what you're doing
# feel free to remove this line. It may cause problems with
# docbook-sgml-utils among other things.
@@ -45,11 +44,10 @@ src_configure() {
strip-flags
econf \
- --disable-dependency-tracking \
--enable-http \
- --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
--enable-default-search-path="${EPREFIX}"/usr/share/sgml \
- --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
$(use_enable nls) \
$(use_enable doc doc-build) \
$(use_enable static-libs static)
@@ -60,23 +58,18 @@ src_compile() {
}
src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
- einfo "Skipping tests known not to work"
- make SHOWSTOPPERS= check || die "Make test failed"
+ # Skipping tests known not to work
+ emake SHOWSTOPPERS= check
SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
}
src_install() {
- emake DESTDIR="${D}" \
- pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} install
+ emake \
+ DESTDIR="${D}" \
+ pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
- dodoc AUTHORS BUGS ChangeLog NEWS README
-}
+ prune_libtool_files
-pkg_postinst() {
- ewarn "Please note that the soname of the library changed."
- ewarn "If you are upgrading from a previous version you need"
- ewarn "to fix dynamic linking inconsistencies by executing:"
- ewarn
- ewarn " revdep-rebuild --library='libosp.so.*'"
+ dodoc AUTHORS BUGS ChangeLog NEWS README
}