summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-30 22:03:02 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-30 22:03:02 +0000
commitbcae956f03ea6faef5ac9effeb71a5f33331c9b2 (patch)
tree2b032302bc4d09085a5f696aef6b8c16d939504e /app-text/opensp/opensp-1.5.2-r3.ebuild
parentMigrate to EAPI=4 and fix static-libs handling #410251 by Fernando V. (diff)
downloadgentoo-2-bcae956f03ea6faef5ac9effeb71a5f33331c9b2.tar.gz
gentoo-2-bcae956f03ea6faef5ac9effeb71a5f33331c9b2.tar.bz2
gentoo-2-bcae956f03ea6faef5ac9effeb71a5f33331c9b2.zip
Fix segfault, bug 196230.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'app-text/opensp/opensp-1.5.2-r3.ebuild')
-rw-r--r--app-text/opensp/opensp-1.5.2-r3.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-text/opensp/opensp-1.5.2-r3.ebuild b/app-text/opensp/opensp-1.5.2-r3.ebuild
new file mode 100644
index 000000000000..af2e9e529aa3
--- /dev/null
+++ b/app-text/opensp/opensp-1.5.2-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.2-r3.ebuild,v 1.1 2012/03/30 22:03:01 floppym Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+MY_P=${P/opensp/OpenSP}
+DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
+HOMEPAGE="http://openjade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
+
+LICENSE="JamesClark"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc nls static-libs test"
+
+DEPEND="nls? ( >=sys-devel/gettext-0.14.5 )
+ doc? (
+ app-text/xmlto
+ ~app-text/docbook-xml-dtd-4.1.2
+ )
+ test? ( app-text/sgml-common )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5-gcc34.patch
+ epatch "${FILESDIR}"/${P}-fix-segfault.patch
+}
+
+src_configure() {
+ #
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ #
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-http \
+ --enable-default-catalog=/etc/sgml/catalog \
+ --enable-default-search-path=/usr/share/sgml \
+ --datadir=/usr/share/sgml/${P} \
+ $(use_enable nls) \
+ $(use_enable doc doc-build) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake pkgdocdir=/usr/share/doc/${PF} || die "Compilation failed"
+}
+
+src_test() {
+ echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ einfo "Skipping tests known not to work"
+ make SHOWSTOPPERS= check || die "Make test failed"
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ pkgdocdir=/usr/share/doc/${PF} install || die "Installation failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed."
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn
+ ewarn " revdep-rebuild --library='libosp.so.*'"
+}