summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-02 05:56:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-02 05:56:24 +0000
commit46e7369e215795eea9bf5f3a57211f7e4413693e (patch)
tree40b57602289cdde418f32ad2adab05d55452a667 /app-text/pelican
parentBump (diff)
downloadgentoo-2-46e7369e215795eea9bf5f3a57211f7e4413693e.tar.gz
gentoo-2-46e7369e215795eea9bf5f3a57211f7e4413693e.tar.bz2
gentoo-2-46e7369e215795eea9bf5f3a57211f7e4413693e.zip
Bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/ChangeLog7
-rw-r--r--app-text/pelican/pelican-3.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index c65032549273..0f0ffe230c46 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.6 2013/04/03 22:20:28 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.7 2013/05/02 05:56:24 patrick Exp $
+
+*pelican-3.2 (02 May 2013)
+
+ 02 May 2013; Patrick Lauer <patrick@gentoo.org> +pelican-3.2.ebuild:
+ Bump
*pelican-3.1.1-r1 (03 Apr 2013)
diff --git a/app-text/pelican/pelican-3.2.ebuild b/app-text/pelican/pelican-3.2.ebuild
new file mode 100644
index 000000000000..9eb8d132d236
--- /dev/null
+++ b/app-text/pelican/pelican-3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.2.ebuild,v 1.1 2013/05/02 05:56:24 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS="README.rst"
+
+python_install() {
+ distutils-r1_python_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "failed to install examples"
+ fi
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)