summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-13 15:45:10 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-13 15:45:10 +0000
commit3fc477084526f359687c2cccad212d708fb18ed6 (patch)
tree0afea79ffca91d43a13af84ae06eff4ebacc2d2e /app-text/pep
parentStable on alpha, bug #332361 (diff)
downloadgentoo-2-3fc477084526f359687c2cccad212d708fb18ed6.tar.gz
gentoo-2-3fc477084526f359687c2cccad212d708fb18ed6.tar.bz2
gentoo-2-3fc477084526f359687c2cccad212d708fb18ed6.zip
Make compilation on Darwin working again (flag-o-matic inherit was dropped), move all Darwin logic to src_prepare
(Portage version: 2.2.01.16365-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-text/pep')
-rw-r--r--app-text/pep/ChangeLog6
-rw-r--r--app-text/pep/pep-2.8-r1.ebuild12
2 files changed, 11 insertions, 7 deletions
diff --git a/app-text/pep/ChangeLog b/app-text/pep/ChangeLog
index 5ef808959009..22247f8fda85 100644
--- a/app-text/pep/ChangeLog
+++ b/app-text/pep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pep/ChangeLog,v 1.18 2010/08/26 22:08:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pep/ChangeLog,v 1.19 2010/09/13 15:45:10 grobian Exp $
+
+ 13 Sep 2010; Fabian Groffen <grobian@gentoo.org> pep-2.8-r1.ebuild:
+ Make compilation on Darwin working again (flag-o-matic inherit was
+ dropped), move all Darwin logic to src_prepare
26 Aug 2010; Jeroen Roovers <jer@gentoo.org> files/pep-2.8-gentoo.patch,
files/pep-2.8-include.patch:
diff --git a/app-text/pep/pep-2.8-r1.ebuild b/app-text/pep/pep-2.8-r1.ebuild
index 10e02c3f4212..1d69f2af9f9c 100644
--- a/app-text/pep/pep-2.8-r1.ebuild
+++ b/app-text/pep/pep-2.8-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8-r1.ebuild,v 1.1 2010/08/26 22:05:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8-r1.ebuild,v 1.2 2010/09/13 15:45:10 grobian Exp $
EAPI="2"
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="General purpose filter and file cleaning program"
HOMEPAGE="http://hannemyr.com/enjoy/pep.html"
@@ -26,14 +26,14 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-include.patch
- # Darwin lacks stricmp
- [[ ${CHOST} == *-darwin* ]] && \
+ # Darwin lacks stricmp and DIRCHAR
+ if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile
+ append-flags "-Dunix" -DSTRICMP
+ fi
}
src_compile() {
- [[ ${CHOST} == *-darwin* ]] && \
- append-flags "-DDIRCHAR=\\'/\\'" -DSTRICMP
# make man page too
make Doc/pep.1 || die "make man page failed"
emake CC="$(tc-getCC)" || die "emake failed"