summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
commit59e70743cc92b4299493d80da7ccd11bbfdb3c3b (patch)
tree1fcbf05e7425ca18392ac8d3997d57fa1ceb2678 /app-text/rcs/rcs-5.7-r1.ebuild
parentNew version (diff)
downloadgentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.gz
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.bz2
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.zip
cleanup
Diffstat (limited to 'app-text/rcs/rcs-5.7-r1.ebuild')
-rw-r--r--app-text/rcs/rcs-5.7-r1.ebuild42
1 files changed, 23 insertions, 19 deletions
diff --git a/app-text/rcs/rcs-5.7-r1.ebuild b/app-text/rcs/rcs-5.7-r1.ebuild
index ad1212094256..a8e175be3d17 100644
--- a/app-text/rcs/rcs-5.7-r1.ebuild
+++ b/app-text/rcs/rcs-5.7-r1.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/rcs/rcs-5.7-r1.ebuild,v 1.3 2001/11/24 18:40:50 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rcs/rcs-5.7-r1.ebuild,v 1.4 2002/04/28 03:59:29 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="Revision Controll System"
-SRC_URI="ftp://ftp.gnu.org/gnu/rcs/${A}"
+DESCRIPTION="Revision Control System"
+SRC_URI="ftp://ftp.gnu.org/gnu/rcs/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/rcs/"
-EPEND="virtual/glibc"
+DEPEND="virtual/glibc"
-REPEND="virtual/glibc
- sys-apps/diffutils"
+RDEPEND="sys-apps/diffutils"
+
src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --host=${CHOST} --with-diffutils
- cp ${FILESDIR}/conf.sh src/conf.sh
- try make
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-diffutils || die
+
+ cp ${FILESDIR}/conf.sh src/conf.sh
+
+ emake || die
}
src_install () {
- cd ${S}
- try make prefix=${D}/usr \
- man1dir=${D}/usr/share/man/man1 \
- man3dir=${D}/usr/share/man/man3 \
- man5dir=${D}/usr/share/man/man5 install
- dodoc ChangeLog COPYING CREDITS NEWS README REFS
-}
+ make \
+ prefix=${D}/usr \
+ man1dir=${D}/usr/share/man/man1 \
+ man3dir=${D}/usr/share/man/man3 \
+ man5dir=${D}/usr/share/man/man5 \
+ install || die
+ dodoc ChangeLog COPYING CREDITS NEWS README REFS
+}