summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-25 11:38:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-25 11:38:54 +0000
commit03b5b38b7562dffdb3af63727d70c8112fca3441 (patch)
treea7ffcba88d85374e3274fd8e308dcb13354cb9f2 /app-text/recode
parentVersion bump to fix #35919. (diff)
downloadgentoo-2-03b5b38b7562dffdb3af63727d70c8112fca3441.tar.gz
gentoo-2-03b5b38b7562dffdb3af63727d70c8112fca3441.tar.bz2
gentoo-2-03b5b38b7562dffdb3af63727d70c8112fca3441.zip
Just rip out the useful chunks from the Debian patchset so we dont have to screw around with autotools.
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/ChangeLog7
-rw-r--r--app-text/recode/files/digest-recode-3.6-r21
-rw-r--r--app-text/recode/files/recode-3.6-debian-11.patch63
-rw-r--r--app-text/recode/recode-3.6-r2.ebuild7
4 files changed, 72 insertions, 6 deletions
diff --git a/app-text/recode/ChangeLog b/app-text/recode/ChangeLog
index 4d373a9bd78d..f0f559135bf3 100644
--- a/app-text/recode/ChangeLog
+++ b/app-text/recode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/recode
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.32 2005/09/25 03:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.33 2005/09/25 11:38:54 vapier Exp $
+
+ 25 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/recode-3.6-debian-11.patch, recode-3.6-r2.ebuild:
+ Just rip out the useful chunks from the Debian patchset so we dont have to
+ screw around with autotools.
*recode-3.6-r2 (25 Sep 2005)
diff --git a/app-text/recode/files/digest-recode-3.6-r2 b/app-text/recode/files/digest-recode-3.6-r2
index 5116a646b78e..06fe5e4c39ed 100644
--- a/app-text/recode/files/digest-recode-3.6-r2
+++ b/app-text/recode/files/digest-recode-3.6-r2
@@ -1,2 +1 @@
MD5 be3f40ad2e93dae5cd5f628264bf1877 recode-3.6.tar.gz 1751886
-MD5 222967f4647e3f9a636d97ffa769e2f3 recode_3.6-11.diff.gz 263880
diff --git a/app-text/recode/files/recode-3.6-debian-11.patch b/app-text/recode/files/recode-3.6-debian-11.patch
new file mode 100644
index 000000000000..d13c2206ae7b
--- /dev/null
+++ b/app-text/recode/files/recode-3.6-debian-11.patch
@@ -0,0 +1,63 @@
+Ripped from Debian patchset 3.6-11
+
+--- recode-3.6.orig/src/libiconv.c
++++ recode-3.6/src/libiconv.c
+@@ -195,12 +195,17 @@
+ memcpy() doesn't do here, because the regions might overlap.
+ memmove() isn't worth it, because we rarely have to move more
+ than 12 bytes. */
+- if (input > input_buffer && input_left > 0)
++ cursor = input_buffer;
++ if (input_left > 0)
+ {
+- cursor = input_buffer;
+- do
+- *cursor++ = *input++;
+- while (--input_left > 0);
++ if (input > input_buffer)
++ {
++ do
++ *cursor++ = *input++;
++ while (--input_left > 0);
++ }
++ else
++ cursor += input_left;
+ }
+ }
+
+--- recode-3.6.orig/src/request.c
++++ recode-3.6/src/request.c
+@@ -1073,7 +1073,7 @@
+ if (task->output.cursor + 4 >= task->output.limit)
+ {
+ RECODE_OUTER outer = task->request->outer;
+- size_t old_size = task->output.limit - task->output.buffer;
++ size_t old_size = task->output.cursor - task->output.buffer;
+ size_t new_size = task->output.cursor + 4 - task->output.buffer;
+
+ /* FIXME: Rethink about how the error should be reported. */
+--- recode-3.6.orig/src/task.c
++++ recode-3.6/src/task.c
+@@ -1198,6 +1198,8 @@
+ else
+ success = transform_mere_copy (subtask);
+
++ task->output = subtask->output;
++
+ if (subtask->input.name && *subtask->input.name)
+ fclose (subtask->input.file);
+ if (subtask->output.name && *subtask->output.name)
+--- recode-3.6.orig/src/hash.h
++++ recode-3.6/src/hash.h
+@@ -21,6 +21,11 @@
+ /* Make sure USE_OBSTACK is defined to 1 if you want the allocator to use
+ obstacks instead of malloc, and recompile `hash.c' with same setting. */
+
++#define hash_lookup recode_hash_lookup
++#define hash_delete recode_hash_delete
++#define hash_free recode_hash_free
++#define hash_insert recode_hash_insert
++
+ #ifndef PARAMS
+ # if PROTOTYPES || __STDC__
+ # define PARAMS(Args) Args
diff --git a/app-text/recode/recode-3.6-r2.ebuild b/app-text/recode/recode-3.6-r2.ebuild
index 2544eb664691..c05a078d83a6 100644
--- a/app-text/recode/recode-3.6-r2.ebuild
+++ b/app-text/recode/recode-3.6-r2.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r2.ebuild,v 1.2 2005/09/25 06:35:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r2.ebuild,v 1.3 2005/09/25 11:38:54 vapier Exp $
inherit flag-o-matic eutils libtool
DEB_VER=11
DESCRIPTION="Convert files between various character sets"
HOMEPAGE="http://recode.progiciels-bpi.ca/"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz
- mirror://debian/pool/main/r/recode/recode_${PV}-${DEB_VER}.diff.gz"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -20,7 +19,7 @@ DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${WORKDIR}"/recode_${PV}-${DEB_VER}.diff
+ epatch "${FILESDIR}"/${P}-debian-${DEB_VER}.patch
if use ppc-macos; then
epatch "${FILESDIR}"/${P}-ppc-macos.diff