summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-06 00:11:46 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-06 00:11:46 +0000
commitb0f5ca3644aceafdb95a771f16cf239319253bec (patch)
tree3a6064d3d97489ef13e256a28564a24ce6c1e1c4 /app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
parentVersion bump, remove old (diff)
downloadgentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.tar.gz
gentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.tar.bz2
gentoo-2-b0f5ca3644aceafdb95a771f16cf239319253bec.zip
add prefix changes
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'app-text/rfcutil/rfcutil-3.2.3-r2.ebuild')
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
new file mode 100644
index 000000000000..d760cb36d18d
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3-r2.ebuild,v 1.1 2012/08/06 00:11:45 ottxor Exp $
+
+EAPI=4
+
+inherit eutils prefix
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="return all related RFCs based upon a number or a search string"
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ || ( www-client/lynx virtual/w3m )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${MY_P}-paths.patch \
+ "${FILESDIR}"/${MY_P}-index.patch
+ eprefixify ${MY_P}
+}
+
+src_install() {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG KNOWN_BUGS README
+ keepdir /var/cache/rfc
+}
+
+pkg_postinst() {
+ elog "Gaarde suggests you make a cron.monthly to run the following:"
+ elog " ${EPREFIX}/usr/bin/rfc -i"
+}
+
+pkg_prerm() {
+ rm -f "${EROOT}"/var/cache/rfc/*
+}