summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-04 17:15:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-04 17:15:03 +0000
commit508e0dc8f379ee11b08e3df6294cef0a2322d27b (patch)
treea07c0db8fe56681d43762248f47efdf8038d0b68 /app-text/rhyme
parentinitial import (diff)
downloadgentoo-2-508e0dc8f379ee11b08e3df6294cef0a2322d27b.tar.gz
gentoo-2-508e0dc8f379ee11b08e3df6294cef0a2322d27b.tar.bz2
gentoo-2-508e0dc8f379ee11b08e3df6294cef0a2322d27b.zip
initial import
Diffstat (limited to 'app-text/rhyme')
-rw-r--r--app-text/rhyme/ChangeLog10
-rw-r--r--app-text/rhyme/Manifest4
-rw-r--r--app-text/rhyme/files/digest-rhyme-0.91
-rw-r--r--app-text/rhyme/metadata.xml12
-rw-r--r--app-text/rhyme/rhyme-0.9.ebuild53
5 files changed, 79 insertions, 1 deletions
diff --git a/app-text/rhyme/ChangeLog b/app-text/rhyme/ChangeLog
new file mode 100644
index 000000000000..bf91f80c886b
--- /dev/null
+++ b/app-text/rhyme/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/rhyme
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rhyme/ChangeLog,v 1.1 2003/09/04 17:14:58 taviso Exp $
+
+*rhyme-0.9 (04 Sep 2003)
+
+ 04 Sep 2003; Tavis Ormandy <taviso@gentoo.org> rhyme-0.9.ebuild:
+ Initial import, Thanks to Aric LeDell <aledell@rcn.com> for
+ submitting the ebuild in #24735
+
diff --git a/app-text/rhyme/Manifest b/app-text/rhyme/Manifest
index daf5222957c2..575ac637d3a7 100644
--- a/app-text/rhyme/Manifest
+++ b/app-text/rhyme/Manifest
@@ -1,2 +1,4 @@
-MD5 fb5f401497332f335b22d215a0e0d464 rhyme-0.9.ebuild 736
+MD5 848c87ab9696989a0c39fd5b046aeb18 rhyme-0.9.ebuild 1282
+MD5 1a004331f1f2278d071cee6af6bcc523 ChangeLog 400
+MD5 4e76ecfb857bcdcc6cc5e59afdc8290b metadata.xml 652
MD5 6d47ed4e336d493694400ed5579fa2a7 files/digest-rhyme-0.9 61
diff --git a/app-text/rhyme/files/digest-rhyme-0.9 b/app-text/rhyme/files/digest-rhyme-0.9
new file mode 100644
index 000000000000..b07b99a820fd
--- /dev/null
+++ b/app-text/rhyme/files/digest-rhyme-0.9
@@ -0,0 +1 @@
+MD5 dd5d6b94d5881e411c86c9a6daabaa70 rhyme-0.9.tar.gz 896013
diff --git a/app-text/rhyme/metadata.xml b/app-text/rhyme/metadata.xml
new file mode 100644
index 000000000000..da31f2f14307
--- /dev/null
+++ b/app-text/rhyme/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>taviso@gentoo.org</email>
+ <name>Tavis Ormandy</name>
+</maintainer>
+<longdescription>
+What is this thing? Why it's a rhyming dictionary, of course! But more specifically, it's a command-line program that takes a word and returns to you a formatted list of all words that rhyme with it. The default response is a perfect rhyme (which is probably what you want). Or you can get a syllable count of a certain word ("whitening" has 2-3 syllables, etc.).
+</longdescription>
+</pkgmetadata>
diff --git a/app-text/rhyme/rhyme-0.9.ebuild b/app-text/rhyme/rhyme-0.9.ebuild
new file mode 100644
index 000000000000..271c734b89cf
--- /dev/null
+++ b/app-text/rhyme/rhyme-0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rhyme/rhyme-0.9.ebuild,v 1.1 2003/09/04 17:14:58 taviso Exp $
+
+inherit ccc
+
+DESCRIPTION="Console based Rhyming Dictionary"
+HOMEPAGE="http://rhyme.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhyme/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.3 )
+ !ncurses? ( >=sys-libs/libtermcap-compat-1.2.3 )
+ >=sys-libs/readline-4.3
+ >=sys-libs/gdbm-1.8.0"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # gcc is hardcoded, switch to user specified compiler
+ replace-cc-hardcode
+
+ # CFLAGS are hardcoded, replace with user specified flags
+ sed -i "s#\(^FLAGS =\).*#\1 ${CFLAGS}#g" ${S}/Makefile
+
+ # termcap is used by default, switch to ncurses if requested.
+ if use ncurses; then
+ sed -i 's/-ltermcap/-lncurses/g' ${S}/Makefile
+ fi
+
+ # works fine with parallel build
+ emake || die
+}
+
+src_install() {
+ # author doesnt use -D for install
+ dodir /usr/share/rhyme /usr/bin /usr/share/man/man1
+
+ einstall BINPATH=${D}/usr/bin \
+ MANPATH=${D}/usr/share/man/man1 \
+ RHYMEPATH=${D}/usr/share/rhyme || die
+
+ dodoc INSTALL COPYING
+
+ prepallman
+}
+