summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-12 20:52:02 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-12 20:52:02 +0000
commitdd4318b3542f87569b9d8e2caba36dfa7f785348 (patch)
treef9ab1088737d6d1c3dae721638729fbf025b6ff2 /app-text/sloccount
parentRevert ~alpha keyword until parsetree works properly (diff)
downloadgentoo-2-dd4318b3542f87569b9d8e2caba36dfa7f785348.tar.gz
gentoo-2-dd4318b3542f87569b9d8e2caba36dfa7f785348.tar.bz2
gentoo-2-dd4318b3542f87569b9d8e2caba36dfa7f785348.zip
Remove silly DEPEND. Respect CC (bug #243752), CFLAGS, LDFLAGS.
(Portage version: 2.2_rc92/cvs/Linux i686)
Diffstat (limited to 'app-text/sloccount')
-rw-r--r--app-text/sloccount/ChangeLog9
-rw-r--r--app-text/sloccount/sloccount-2.26-r2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-text/sloccount/ChangeLog b/app-text/sloccount/ChangeLog
index dab8e04ce093..fc9241dbe793 100644
--- a/app-text/sloccount/ChangeLog
+++ b/app-text/sloccount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sloccount
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sloccount/ChangeLog,v 1.22 2008/12/09 21:33:31 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sloccount/ChangeLog,v 1.23 2010/10/12 20:52:02 jer Exp $
+
+*sloccount-2.26-r2 (12 Oct 2010)
+
+ 12 Oct 2010; Jeroen Roovers <jer@gentoo.org> +sloccount-2.26-r2.ebuild:
+ Remove silly DEPEND. Respect CC (bug #243752), CFLAGS, LDFLAGS.
09 Dec 2008; Raúl Porcel <armin76@gentoo.org> sloccount-2.26-r1.ebuild:
Add ~alpha wrt #250343
diff --git a/app-text/sloccount/sloccount-2.26-r2.ebuild b/app-text/sloccount/sloccount-2.26-r2.ebuild
new file mode 100644
index 000000000000..29ca02dd5fca
--- /dev/null
+++ b/app-text/sloccount/sloccount-2.26-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sloccount/sloccount-2.26-r2.ebuild,v 1.1 2010/10/12 20:52:02 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for counting Source Lines of Code (SLOC) for a large number of languages"
+HOMEPAGE="http://www.dwheeler.com/sloccount/"
+SRC_URI="http://www.dwheeler.com/sloccount/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND="dev-lang/perl
+ >=sys-apps/sed-4
+ app-shells/bash"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libexec.patch
+ epatch "${FILESDIR}"/${P}-coreutils-tail-n-fix.patch
+
+ sed -i \
+ -e 's|^CC=gcc|CFLAGS+=|g' \
+ -e 's|$(CC)|& $(CFLAGS) $(LDFLAGS)|g' \
+ -e '/^DOC_DIR/ { s/-$(RPM_VERSION)//g }' \
+ -e '/^MYDOCS/ { s/[^ =]\+\.html//g }' \
+ makefile || die "sed makefile failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ einstall PREFIX="${D}/usr" DOC_DIR="${D}/usr/share/doc/${PF}/" || die
+ prepalldocs
+ dohtml *html
+}