summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-03 02:30:39 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-03 02:30:39 +0000
commite3cbe3296c8c731999141d8233ef5a5584a573ae (patch)
tree9f3c8f5d858efc49243a9eda5e2e3a45e4bbf54e /app-text/tkman
parentrman 3.0.9 ebuild submitted by jim@nuttz.org (Jim Nutt) (diff)
downloadgentoo-2-e3cbe3296c8c731999141d8233ef5a5584a573ae.tar.gz
gentoo-2-e3cbe3296c8c731999141d8233ef5a5584a573ae.tar.bz2
gentoo-2-e3cbe3296c8c731999141d8233ef5a5584a573ae.zip
tkman 2.1 ebuild submitted by jim@nuttz.org (Jim Nutt)
Diffstat (limited to 'app-text/tkman')
-rw-r--r--app-text/tkman/files/digest-tkman-2.11
-rw-r--r--app-text/tkman/files/tkman-2.1-gentoo.diff68
-rw-r--r--app-text/tkman/tkman-2.1.ebuild29
3 files changed, 98 insertions, 0 deletions
diff --git a/app-text/tkman/files/digest-tkman-2.1 b/app-text/tkman/files/digest-tkman-2.1
new file mode 100644
index 000000000000..f6996764f9fb
--- /dev/null
+++ b/app-text/tkman/files/digest-tkman-2.1
@@ -0,0 +1 @@
+MD5 c9ecaacf83a30f36ed0995ba51fdd33f tkman.tar.gz 224735
diff --git a/app-text/tkman/files/tkman-2.1-gentoo.diff b/app-text/tkman/files/tkman-2.1-gentoo.diff
new file mode 100644
index 000000000000..9b9bb976de4f
--- /dev/null
+++ b/app-text/tkman/files/tkman-2.1-gentoo.diff
@@ -0,0 +1,68 @@
+--- tkman-2.1/Makefile Thu Jun 22 15:39:42 2000
++++ tkman-2.1-gentoo/Makefile Fri Feb 1 17:51:18 2002
+@@ -26,14 +26,16 @@
+ ### you need to localize the paths on these lines
+
+ #WISH = /usr/sww/tcl-8.3/bin/wish
+-WISH = /private/share/bin/wish
++#WISH = /private/share/bin/wish
+ #WISH = /private/share/bin/wish8.3
+ #WISH = /usr/local/bin/wish8.3
++WISH = /usr/bin/wish8.3
+
+ # the executable `tkman' is placed in BINDIR
+ # this should be a directory that's in your bin PATH
+-BINDIR = /private/share/bin
++#BINDIR = /private/share/bin
+ #BINDIR = /usr/local/bin
++BINDIR = ${DESTDIR}/usr/bin
+
+
+ # OPTIONAL
+@@ -81,7 +83,7 @@
+ # will examine for matches if a search in the usual locations fails while searching
+ # for a man pages and displaying its associated binaries (if any).
+ # Use this feature carefully as a large number of directories can slow down startup.
+-mastermen = "/usr/man /usr/local/man"
++mastermen = "/usr/share/man /usr/local/man"
+ #mastermen = "/usr/man /usr/local/man /usr/sww/man /usr/share/man /usr/kerberos/man"
+ masterbin = "/usr/bin /usr/local/bin"
+ #masterbin = "/usr/bin /usr/local/bin /usr/sww/bin /usr/sww/share/bin /usr/sww/share/X11R5/bin"
+@@ -202,9 +204,9 @@
+ # the right-topmost menu's Rebuild Database/Glimpse Index menu choice.
+
+ # BY DEFAULT ON (Boolean scope set to entire file)
+-glimpse = "glimpse -W"
++#glimpse = "glimpse -W"
+ # IF YOU DON'T WANT TO BOTHER WITH GLIMPSE, you can disable it here
+-#glimpse = ""
++glimpse = ""
+ # give the full path, if you'd like
+ #glimpse = /usr/sww/bin/glimpse
+ # variations (refer to the Glimpse manual page)
+@@ -229,11 +231,11 @@
+ #glimpseindex = "glimpseindex -o -B"
+ # To shorten most index build times by incrementally building index when possible.
+ # For me, this drops indexing time from ~25 minutes to ~3 minutes, depending
+-glimpseindex = "glimpseindex -o -B -f"
++#glimpseindex = "glimpseindex -o -B -f"
+ # -M 8 gives 8MB of main memory instead of default 2, which speeds up indexing, maybe
+ #glimpseindex = "glimpseindex -o -B -f -M 8"
+ # if you don't want give the power to index, disable glimpseindex here
+-#glimpseindex = ""
++glimpseindex = ""
+ #glimpseindex = "/usr/sww/bin/glimpseindex -o -B"
+ # compressed manual pages are handled automatically; don't add -z to above
+
+@@ -290,9 +292,9 @@
+ rman = rman
+ #rman = /private/phelps/bin/rman
+
+-apropos = {man -k}
++#apropos = {man -k}
+ # Linux uses a shell script instead:
+-#apropos = apropos
++apropos = apropos
+ # if don't have apropos (maybe on Windoze)
+ #apropos = ""
+
diff --git a/app-text/tkman/tkman-2.1.ebuild b/app-text/tkman/tkman-2.1.ebuild
new file mode 100644
index 000000000000..37a81505a5c7
--- /dev/null
+++ b/app-text/tkman/tkman-2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: jim nutt <jim@nuttz.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/tkman/tkman-2.1.ebuild,v 1.1 2002/02/03 02:30:39 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TkMan man and info page browser"
+A=tkman.tar.gz
+SRC_URI="http://tkman.sourceforge.net/tkman.tar.gz"
+HOMEPAGE="http://tkman.sourceforge.net/"
+
+DEPEND=">=app-text/rman-3.0.9
+ >=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 <${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dobin ${PN}
+ dobin re${PN}
+}