summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-27 23:17:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-27 23:17:52 +0000
commit49d0b59ce7bc4ed407b6ceedf2706ea1c240d787 (patch)
treec0408806a73c33bff8d068e28ca3b93ac70eadaa /app-text/tree
parentAdded ~alpha, bug 379651. (diff)
downloadgentoo-2-49d0b59ce7bc4ed407b6ceedf2706ea1c240d787.tar.gz
gentoo-2-49d0b59ce7bc4ed407b6ceedf2706ea1c240d787.tar.bz2
gentoo-2-49d0b59ce7bc4ed407b6ceedf2706ea1c240d787.zip
patch bash-completion support to handle files with whitespace (bug #417715) with patch from poletti.marco@gmail.com; rev bump to push out
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/tree')
-rw-r--r--app-text/tree/ChangeLog11
-rw-r--r--app-text/tree/files/tree.bashcomp10
-rw-r--r--app-text/tree/tree-1.5.3.ebuild38
-rw-r--r--app-text/tree/tree-1.6.0-r1.ebuild39
4 files changed, 53 insertions, 45 deletions
diff --git a/app-text/tree/ChangeLog b/app-text/tree/ChangeLog
index cf5088841b18..562078d62916 100644
--- a/app-text/tree/ChangeLog
+++ b/app-text/tree/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/tree
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tree/ChangeLog,v 1.93 2011/12/29 21:52:30 halcy0n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/ChangeLog,v 1.94 2012/05/27 23:17:52 mr_bones_ Exp $
+
+*tree-1.6.0-r1 (27 May 2012)
+
+ 27 May 2012; Michael Sterrett <mr_bones_@gentoo.org> -tree-1.5.3.ebuild,
+ +tree-1.6.0-r1.ebuild, files/tree.bashcomp:
+ patch bash-completion support to handle files with whitespace (bug #417715)
+ with patch from poletti.marco@gmail.com; rev bump to push out
29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> tree-1.6.0.ebuild:
Stable for ppc/ppc64; bug #380175
diff --git a/app-text/tree/files/tree.bashcomp b/app-text/tree/files/tree.bashcomp
index b5da3ee5c6bb..5c81b10158ec 100644
--- a/app-text/tree/files/tree.bashcomp
+++ b/app-text/tree/files/tree.bashcomp
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tree/files/tree.bashcomp,v 1.1 2005/08/30 14:15:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/files/tree.bashcomp,v 1.2 2012/05/27 23:17:52 mr_bones_ Exp $
# bash command-line completion for tree
# Author: Aaron Walker <ka0ttic@gentoo.org>
@@ -15,7 +15,7 @@ _tree() {
--dirsfirst --charset --help"
if [[ ${cur} == -* ]] ; then
- COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
+ COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
return 0
fi
@@ -23,10 +23,10 @@ _tree() {
-L|-P|-I|-H|-T|--charset|--help)
;;
-o)
- COMPREPLY=( $(compgen -f -- ${cur}) )
+ _filedir
;;
*)
- COMPREPLY=( $(compgen -d -- ${cur}) )
+ _filedir -d
;;
esac
}
diff --git a/app-text/tree/tree-1.5.3.ebuild b/app-text/tree/tree-1.5.3.ebuild
deleted file mode 100644
index c682f9cddd95..000000000000
--- a/app-text/tree/tree-1.5.3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.5.3.ebuild,v 1.10 2011/07/21 16:32:32 mr_bones_ Exp $
-
-EAPI=2
-inherit toolchain-funcs flag-o-matic bash-completion
-
-DESCRIPTION="Lists directories recursively, and produces an indented listing of files."
-HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
-SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-src_prepare() {
- sed -i \
- -e 's:LINUX:__linux__:' tree.c \
- || die "sed failed"
-}
-
-src_compile() {
- append-lfs-flags
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- XOBJS="$(use elibc_uclibc && echo strverscmp.o)" \
- || die "emake failed"
-}
-
-src_install() {
- dobin tree || die "dobin failed"
- doman man/tree.1 || die
- dodoc CHANGES README* || die
- dobashcompletion "${FILESDIR}"/${PN}.bashcomp
-}
diff --git a/app-text/tree/tree-1.6.0-r1.ebuild b/app-text/tree/tree-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..2b9a17aab493
--- /dev/null
+++ b/app-text/tree/tree-1.6.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.6.0-r1.ebuild,v 1.1 2012/05/27 23:17:52 mr_bones_ Exp $
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files."
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e 's:LINUX:__linux__:' tree.c \
+ || die "sed failed"
+ mv doc/tree.1.fr doc/tree.fr.1
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ XOBJS="$(use elibc_uclibc && echo strverscmp.o)"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ dodoc CHANGES README*
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}