summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-06-28 19:45:45 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-06-28 19:45:45 +0000
commitca233eede96204dbf19e6238bc4ac35978624ec8 (patch)
tree70b12c58c2df4983cddef7712c70d7bb18c32ee3 /app-text/xmldiff
parentppc stable, bug #181097 (diff)
downloadgentoo-2-ca233eede96204dbf19e6238bc4ac35978624ec8.tar.gz
gentoo-2-ca233eede96204dbf19e6238bc4ac35978624ec8.tar.bz2
gentoo-2-ca233eede96204dbf19e6238bc4ac35978624ec8.zip
Fixing stupid cvs breakage thanks to Chris Mayo. Fixes bug #183566
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/ChangeLog6
-rw-r--r--app-text/xmldiff/files/xmldiff-0.6.8-python2.5.patch30
-rw-r--r--app-text/xmldiff/xmldiff-0.6.8.ebuild4
3 files changed, 7 insertions, 33 deletions
diff --git a/app-text/xmldiff/ChangeLog b/app-text/xmldiff/ChangeLog
index cfa1a005a228..b628d540e47c 100644
--- a/app-text/xmldiff/ChangeLog
+++ b/app-text/xmldiff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/xmldiff
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/ChangeLog,v 1.1 2007/06/28 00:38:05 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/ChangeLog,v 1.2 2007/06/28 19:45:45 coldwind Exp $
+
+ 28 Jun 2007; Santiago M. Mola <coldwind@gentoo.org>
+ -files/xmldiff-0.6.8-python2.5.patch:
+ Fixing stupid cvs breakage thanks to Chris Mayo. Fixes bug #183566
*xmldiff-0.6.8 (28 Jun 2007)
diff --git a/app-text/xmldiff/files/xmldiff-0.6.8-python2.5.patch b/app-text/xmldiff/files/xmldiff-0.6.8-python2.5.patch
deleted file mode 100644
index fbdc774ee5ca..000000000000
--- a/app-text/xmldiff/files/xmldiff-0.6.8-python2.5.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -ur xmldiff-0.6.8.orig/setup.py xmldiff-0.6.8/setup.py
---- xmldiff-0.6.8.orig/setup.py 2007-06-07 23:55:05.000000000 +0200
-+++ xmldiff-0.6.8/setup.py 2007-06-07 23:55:21.000000000 +0200
-@@ -17,10 +17,10 @@
- # this program; if not, write to the Free Software Foundation, Inc.,
- # 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- """ Generic Setup script, takes package info from __pkginfo__.py file """
-+from __future__ import nested_scopes
-
- __revision__ = '$Id: xmldiff-0.6.8-python2.5.patch,v 1.1 2007/06/28 00:38:05 coldwind Exp $'
-
--from __future__ import nested_scopes
- import os
- import sys
- import shutil
-diff -ur xmldiff-0.6.8.orig/test/regrtest.py xmldiff-0.6.8/test/regrtest.py
---- xmldiff-0.6.8.orig/test/regrtest.py 2007-06-07 23:55:05.000000000 +0200
-+++ xmldiff-0.6.8/test/regrtest.py 2007-06-07 23:55:43.000000000 +0200
-@@ -1,9 +1,10 @@
- """
- xmldiff non regression test
- """
-+from __future__ import nested_scopes
-+
- __revision__ = "$Id: xmldiff-0.6.8-python2.5.patch,v 1.1 2007/06/28 00:38:05 coldwind Exp $"
-
--from __future__ import nested_scopes
- from os.path import join, basename
- from cStringIO import StringIO
- import sys
diff --git a/app-text/xmldiff/xmldiff-0.6.8.ebuild b/app-text/xmldiff/xmldiff-0.6.8.ebuild
index a803094caef2..d4be98410e90 100644
--- a/app-text/xmldiff/xmldiff-0.6.8.ebuild
+++ b/app-text/xmldiff/xmldiff-0.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/xmldiff-0.6.8.ebuild,v 1.1 2007/06/28 00:38:05 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmldiff/xmldiff-0.6.8.ebuild,v 1.2 2007/06/28 19:45:45 coldwind Exp $
inherit eutils distutils
@@ -22,5 +22,5 @@ DOCS="ChangeLog README README.xmlrev TODO"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-python2.5.patch"
+ sed -i -e "/^__revision__/d" setup.py test/regrtest.py || die "sed failed"
}