summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2012-03-19 06:12:15 +0000
committerPeter Volkov <pva@gentoo.org>2012-03-19 06:12:15 +0000
commita2fb630f31f1ed8dde115ff709a49a736793a802 (patch)
treeb29f4cdf41668f26925ea8f75fc844e165c0b14a /app-text/yagf/yagf-0.9.ebuild
parentold, no internal CK support (diff)
downloadgentoo-2-a2fb630f31f1ed8dde115ff709a49a736793a802.tar.gz
gentoo-2-a2fb630f31f1ed8dde115ff709a49a736793a802.tar.bz2
gentoo-2-a2fb630f31f1ed8dde115ff709a49a736793a802.zip
Version bump, bug #395509, thank yaleks for this job. Drop old.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-text/yagf/yagf-0.9.ebuild')
-rw-r--r--app-text/yagf/yagf-0.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/yagf/yagf-0.9.ebuild b/app-text/yagf/yagf-0.9.ebuild
new file mode 100644
index 000000000000..a74627bc1eab
--- /dev/null
+++ b/app-text/yagf/yagf-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/yagf/yagf-0.9.ebuild,v 1.1 2012/03/19 06:12:15 pva Exp $
+
+EAPI="4"
+inherit cmake-utils
+
+DESCRIPTION="Graphical front-end for cuneiform and tesseract OCR tools"
+HOMEPAGE="http://symmetrica.net/cuneiform-linux/yagf-en.html"
+SRC_URI="http://symmetrica.net/cuneiform-linux/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scanner +cuneiform tesseract pdf"
+
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+DEPEND=">=x11-libs/qt-gui-4.7
+ app-text/aspell"
+RDEPEND="${DEPEND}
+ cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+ scanner? ( media-gfx/xsane )
+ pdf? ( || ( app-text/poppler[utils] app-text/ghostscript-gpl ) )"
+
+DOCS="AUTHORS ChangeLog DESCRIPTION README"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-mdv-linkage.patch
+}