summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-28 11:15:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-28 11:15:58 +0000
commit2df29d55ccb29e35847c99d7038a0a560b702257 (patch)
tree6a7d467be833364f3ef766dca9d5ebb68a6ff1d9 /app-text
parentUse $(PYTHON -f) instead of python. (diff)
downloadgentoo-2-2df29d55ccb29e35847c99d7038a0a560b702257.tar.gz
gentoo-2-2df29d55ccb29e35847c99d7038a0a560b702257.tar.bz2
gentoo-2-2df29d55ccb29e35847c99d7038a0a560b702257.zip
Version Bump, per 304987
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/multitail/ChangeLog8
-rw-r--r--app-text/multitail/multitail-5.2.6.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-text/multitail/ChangeLog b/app-text/multitail/ChangeLog
index e8470fe00876..8a718d242544 100644
--- a/app-text/multitail/ChangeLog
+++ b/app-text/multitail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/multitail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.71 2010/02/03 21:47:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.72 2010/02/28 11:15:58 jlec Exp $
+
+*multitail-5.2.6 (28 Feb 2010)
+
+ 28 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +multitail-5.2.6.ebuild:
+ Version Bump, per 304987
*multitail-5.2.2-r1 (03 Feb 2010)
diff --git a/app-text/multitail/multitail-5.2.6.ebuild b/app-text/multitail/multitail-5.2.6.ebuild
new file mode 100644
index 000000000000..b5b98ce5ec45
--- /dev/null
+++ b/app-text/multitail/multitail-5.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-5.2.6.ebuild,v 1.1 2010/02/28 11:15:58 jlec Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/5.2.2-as-needed.patch"
+}
+
+src_configure() {
+ tc-export CC
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_install () {
+ dobin multitail || die
+
+ insinto /etc
+ doins multitail.conf || die
+
+ dodoc Changes readme.txt thanks.txt || die
+ doman multitail.1 || die
+
+ if use examples; then
+ docinto examples
+ dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl || die
+ fi
+
+ if use doc; then
+ dohtml manual.html || die
+ fi
+}