summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2004-10-03 22:36:46 +0000
committerAnders Rune Jensen <arj@gentoo.org>2004-10-03 22:36:46 +0000
commit47d3fb9158607f99f2b2a22cd876bb236a42c284 (patch)
tree6e89054218f3e8888211eb9e5eeeaeed8d340816 /app-text
parentVersion bump to 2004a. Closes #57177. (Manifest recommit) (diff)
downloadgentoo-2-47d3fb9158607f99f2b2a22cd876bb236a42c284.tar.gz
gentoo-2-47d3fb9158607f99f2b2a22cd876bb236a42c284.tar.bz2
gentoo-2-47d3fb9158607f99f2b2a22cd876bb236a42c284.zip
new version
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/Manifest16
-rw-r--r--app-text/aspell/aspell-0.60.ebuild68
-rw-r--r--app-text/aspell/files/digest-aspell-0.601
4 files changed, 79 insertions, 13 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index c841f5dce813..7a0ad92af044 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.59 2004/09/05 23:30:01 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.60 2004/10/03 22:36:46 arj Exp $
+*aspell-0.60 (03 Oct 2004)
+
+ 03 Oct 2004; Anders Rune Jensen <arj@gentoo.org> +aspell-0.60.ebuild:
+ new version. Fixes #65133.
+
06 Sep 2004; Ciaran McCreesh <ciaranm@gentoo.org> aspell-0.50.5-r2.ebuild,
aspell-0.50.5-r4.ebuild:
Switch to use epause and ebeep, bug #62950
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index b309492d4955..e58bad319b72 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 88e4e4d7a859bd74c3ea78c47c17cb63 ChangeLog 10146
MD5 6c043aa59a4b7941b67c2ee6c1f8a461 aspell-0.50.5-r2.ebuild 1861
-MD5 fb4cdd3c2e5007eadc6a7df8fcb03c93 aspell-0.50.5-r4.ebuild 1831
MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
+MD5 fb4cdd3c2e5007eadc6a7df8fcb03c93 aspell-0.50.5-r4.ebuild 1831
+MD5 9321730b765f96e4c9aa0d52e8558178 aspell-0.60.ebuild 1584
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
+MD5 02560c627d075d243720f1067bf45bcf files/aspell-buffer-fix.patch 1556
MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r2 66
MD5 ec7c300a1661ae94b55736f74a045bab files/aspell-quotechar-fix.patch 473
-MD5 02560c627d075d243720f1067bf45bcf files/aspell-buffer-fix.patch 1556
MD5 d2091b79a60b395e1ce3c496b7e3d45a files/aspell-0.50.5-charcount.patch 2264
MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r4 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBUlK8HTu7gpaalycRApI0AJ0UEXEkZrl2RBJVsDRJAi5xzzILGwCfcof1
-8E4NLcW70kgvBPwwqXgnm9Q=
-=Sxa8
------END PGP SIGNATURE-----
+MD5 337afb25ae875e8dbe3336d493b5e3de files/digest-aspell-0.60 64
diff --git a/app-text/aspell/aspell-0.60.ebuild b/app-text/aspell/aspell-0.60.ebuild
new file mode 100644
index 000000000000..ea4739aaf174
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.ebuild,v 1.1 2004/10/03 22:36:46 arj Exp $
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gpm"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ [ "${ARCH}" == "ppc" ] && append-flags -O2 -fsigned-char
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}
diff --git a/app-text/aspell/files/digest-aspell-0.60 b/app-text/aspell/files/digest-aspell-0.60
new file mode 100644
index 000000000000..fc217ea1529d
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.60
@@ -0,0 +1 @@
+MD5 8fa031d0eb37a5538aa6fefa657e707f aspell-0.60.tar.gz 1622677