summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-04-10 19:05:45 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-04-10 19:05:45 +0000
commit59cc8406429acb232250c1f07150b9fb81c56f03 (patch)
tree8e6e07f1cd5326cb5d318f770dc19892c5d29952 /app-text
parentfix #216992 (diff)
downloadgentoo-2-59cc8406429acb232250c1f07150b9fb81c56f03.tar.gz
gentoo-2-59cc8406429acb232250c1f07150b9fb81c56f03.tar.bz2
gentoo-2-59cc8406429acb232250c1f07150b9fb81c56f03.zip
Make dependencies compatible with split Qt:4, fixing bug #217186.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog6
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild8
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild10
3 files changed, 16 insertions, 8 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 04244b984b2f..2d5f41f8442b 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.83 2008/04/01 16:18:44 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.84 2008/04/10 19:05:45 tgurr Exp $
+
+ 10 Apr 2008; Timo Gurr <tgurr@gentoo.org> poppler-bindings-0.5.3.ebuild,
+ poppler-bindings-0.8.0.ebuild:
+ Make dependencies compatible with split Qt:4, fixing bug #217186.
*poppler-bindings-0.8.0 (01 Apr 2008)
diff --git a/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
index 1a7ab584fb79..a5db17d219f1 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild,v 1.19 2008/03/01 04:54:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.5.3.ebuild,v 1.20 2008/04/10 19:05:45 tgurr Exp $
inherit autotools eutils multilib
@@ -32,9 +32,9 @@ S="${WORKDIR}/${MY_P}"
src_unpack(){
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/poppler-0.5.2-bindings.patch
+ epatch "${FILESDIR}"/poppler-0.5.2-bindings.patch
AT_M4DIR="m4" eautoreconf
sed -i s:/usr/lib/qt:/usr/lib/qt4: configure
@@ -63,7 +63,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
}
pkg_postinst() {
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
index e0d80042a378..19bd500f4b5e 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild,v 1.1 2008/04/01 16:18:44 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild,v 1.2 2008/04/10 19:05:45 tgurr Exp $
+EAPI="1"
inherit autotools eutils multilib
MY_P=${P/-bindings/}
@@ -30,11 +31,14 @@ RDEPEND="~app-text/poppler-${PV}
>=gnome-base/libglade-2
)
qt3? ( =x11-libs/qt-3* )
- qt4? ( =x11-libs/qt-4* )"
+ qt4? ( || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+ >=x11-libs/qt-4.3:4 ) )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack(){
unpack ${A}