summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-04-11 00:20:53 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-04-11 00:20:53 +0000
commit5d9b32237beefa7a4862e4391936d7c7c86f3779 (patch)
tree122840cb2dddd95afcb3f0104bc291ca9d60dc37 /app-text
parentAdjust dependency for split qt-4. (diff)
downloadgentoo-2-5d9b32237beefa7a4862e4391936d7c7c86f3779.tar.gz
gentoo-2-5d9b32237beefa7a4862e4391936d7c7c86f3779.tar.bz2
gentoo-2-5d9b32237beefa7a4862e4391936d7c7c86f3779.zip
Disable the qt4 password test; it depends on a pdf that cannot be distributed. Bug #201448
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog9
-rw-r--r--app-text/poppler-bindings/files/poppler-0.6.3-no-password-test.patch11
-rw-r--r--app-text/poppler-bindings/files/poppler-0.8.0-no-password-test.patch11
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild5
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild5
5 files changed, 38 insertions, 3 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 2d5f41f8442b..f8abd37f2c3c 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.84 2008/04/10 19:05:45 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.85 2008/04/11 00:20:52 dang Exp $
+
+ 11 Apr 2008; Daniel Gryniewicz <dang@gentoo.org>
+ +files/poppler-0.6.3-no-password-test.patch,
+ +files/poppler-0.8.0-no-password-test.patch,
+ poppler-bindings-0.6.3.ebuild, poppler-bindings-0.8.0.ebuild:
+ Disable the qt4 password test; it depends on a pdf that cannot be
+ distributed. Bug #201448
10 Apr 2008; Timo Gurr <tgurr@gentoo.org> poppler-bindings-0.5.3.ebuild,
poppler-bindings-0.8.0.ebuild:
diff --git a/app-text/poppler-bindings/files/poppler-0.6.3-no-password-test.patch b/app-text/poppler-bindings/files/poppler-0.6.3-no-password-test.patch
new file mode 100644
index 000000000000..e6e2590ab29b
--- /dev/null
+++ b/app-text/poppler-bindings/files/poppler-0.6.3-no-password-test.patch
@@ -0,0 +1,11 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN poppler-0.6.3.orig/qt4/tests/Makefile.am poppler-0.6.3/qt4/tests/Makefile.am
+--- poppler-0.6.3.orig/qt4/tests/Makefile.am 2007-11-04 18:11:23.000000000 -0500
++++ poppler-0.6.3/qt4/tests/Makefile.am 2008-04-10 19:57:38.000000000 -0400
+@@ -63,7 +63,6 @@ TESTS = \
+ check_metadata \
+ check_permissions \
+ check_pagemode \
+- check_password \
+ check_pagelayout
+
+ check_PROGRAMS = $(TESTS)
diff --git a/app-text/poppler-bindings/files/poppler-0.8.0-no-password-test.patch b/app-text/poppler-bindings/files/poppler-0.8.0-no-password-test.patch
new file mode 100644
index 000000000000..8a46fee7f572
--- /dev/null
+++ b/app-text/poppler-bindings/files/poppler-0.8.0-no-password-test.patch
@@ -0,0 +1,11 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN poppler-0.8.0.orig/qt4/tests/Makefile.am poppler-0.8.0/qt4/tests/Makefile.am
+--- poppler-0.8.0.orig/qt4/tests/Makefile.am 2008-03-22 14:11:44.000000000 -0400
++++ poppler-0.8.0/qt4/tests/Makefile.am 2008-04-10 20:08:33.000000000 -0400
+@@ -67,7 +67,6 @@ TESTS = \
+ check_optcontent \
+ check_permissions \
+ check_pagemode \
+- check_password \
+ check_pagelayout \
+ check_search
+
diff --git a/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
index 5b5461cb3abc..fb0904f77a6a 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild,v 1.2 2008/03/01 04:54:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild,v 1.3 2008/04/11 00:20:52 dang Exp $
inherit autotools eutils multilib
@@ -42,6 +42,9 @@ src_unpack(){
epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+ # Don't run password test; the test file is not there. Bug #201448
+ epatch "${FILESDIR}"/poppler-0.6.3-no-password-test.patch
+
AT_M4DIR="m4" eautoreconf
}
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
index 19bd500f4b5e..eec9b8bf8936 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild,v 1.2 2008/04/10 19:05:45 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.0.ebuild,v 1.3 2008/04/11 00:20:52 dang Exp $
EAPI="1"
inherit autotools eutils multilib
@@ -46,6 +46,9 @@ src_unpack(){
epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+ # Don't run password test; the test file is not there. Bug #201448
+ epatch "${FILESDIR}"/poppler-0.8.0-no-password-test.patch
+
AT_M4DIR="m4" eautoreconf
cd poppler
ln -s /usr/lib/libpoppler.la