summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-09 16:30:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-09 16:30:04 +0000
commit77f06e0ef193e84bbcf847b3ea68d685eb085be1 (patch)
tree012b8109705ef9abcdc8a0944757d4be88a7386b /app-text
parentold (diff)
downloadgentoo-2-77f06e0ef193e84bbcf847b3ea68d685eb085be1.tar.gz
gentoo-2-77f06e0ef193e84bbcf847b3ea68d685eb085be1.tar.bz2
gentoo-2-77f06e0ef193e84bbcf847b3ea68d685eb085be1.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdf2djvu/ChangeLog9
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.7.16.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/app-text/pdf2djvu/ChangeLog b/app-text/pdf2djvu/ChangeLog
index 7a9050bd5213..a4b154ef9d4c 100644
--- a/app-text/pdf2djvu/ChangeLog
+++ b/app-text/pdf2djvu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pdf2djvu
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.15 2012/10/25 11:26:30 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.16 2013/01/09 16:30:04 ssuominen Exp $
+
+*pdf2djvu-0.7.16 (09 Jan 2013)
+
+ 09 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +pdf2djvu-0.7.16.ebuild:
+ Version bump.
*pdf2djvu-0.7.15 (25 Oct 2012)
diff --git a/app-text/pdf2djvu/pdf2djvu-0.7.16.ebuild b/app-text/pdf2djvu/pdf2djvu-0.7.16.ebuild
new file mode 100644
index 000000000000..08547555e88f
--- /dev/null
+++ b/app-text/pdf2djvu/pdf2djvu-0.7.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.16.ebuild,v 1.1 2013/01/09 16:30:04 ssuominen Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to create DjVu files from PDF files"
+HOMEPAGE="http://code.google.com/p/pdf2djvu/"
+SRC_URI="http://pdf2djvu.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graphicsmagick nls openmp test"
+
+RDEPEND="
+ >=app-text/djvu-3.5.21
+ >=app-text/poppler-0.16.7
+ dev-libs/libxml2
+ dev-libs/libxslt
+ graphicsmagick? ( media-gfx/graphicsmagick )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/pstreams
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-python/nose )
+"
+
+REQUIRED_USE="test? ( graphicsmagick )"
+
+src_configure() {
+ local openmp=--disable-openmp
+ use openmp && tc-has-openmp && openmp=--enable-openmp
+
+ econf \
+ ${openmp} \
+ $(use_enable nls) \
+ $(use_with graphicsmagick)
+}
+
+src_install() {
+ default
+ dodoc doc/{changelog,{cjk,credits,djvudigital}.txt}
+}