summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-17 07:44:06 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-17 07:44:06 +0000
commit8e1880e770fc3c875c9fe35f98211f875aa568a1 (patch)
tree08bb48ea134919992226eb4400833edff9966222 /app-text
parentversion bump and gtk1 is now optional (diff)
downloadgentoo-2-8e1880e770fc3c875c9fe35f98211f875aa568a1.tar.gz
gentoo-2-8e1880e770fc3c875c9fe35f98211f875aa568a1.tar.bz2
gentoo-2-8e1880e770fc3c875c9fe35f98211f875aa568a1.zip
Security update.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ggv/ChangeLog6
-rw-r--r--app-text/ggv/files/digest-ggv-1.99.90-r11
-rw-r--r--app-text/ggv/files/ggv-1.99.90-r1-gentoo.diff152
-rw-r--r--app-text/ggv/ggv-1.99.90-r1.ebuild40
4 files changed, 198 insertions, 1 deletions
diff --git a/app-text/ggv/ChangeLog b/app-text/ggv/ChangeLog
index daa0abbc18ee..87184d9dd799 100644
--- a/app-text/ggv/ChangeLog
+++ b/app-text/ggv/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-text/ggv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ChangeLog,v 1.15 2002/09/06 05:03:28 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ChangeLog,v 1.16 2002/10/17 07:44:06 aliz Exp $
+*ggv-1.99.90-r1 (17 Oct 2002)
+
+ 17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update.
*ggv-1.99.90 (06 Sep 2002)
06 Sep 2002; Spider <spider@gentoo.org> ggv-1.99.90.ebuild :
diff --git a/app-text/ggv/files/digest-ggv-1.99.90-r1 b/app-text/ggv/files/digest-ggv-1.99.90-r1
new file mode 100644
index 000000000000..ca586b2bd065
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-1.99.90-r1
@@ -0,0 +1 @@
+MD5 9a84c8f7555d1388b2e40252c53bc965 ggv-1.99.90.tar.bz2 565117
diff --git a/app-text/ggv/files/ggv-1.99.90-r1-gentoo.diff b/app-text/ggv/files/ggv-1.99.90-r1-gentoo.diff
new file mode 100644
index 000000000000..d5283539f352
--- /dev/null
+++ b/app-text/ggv/files/ggv-1.99.90-r1-gentoo.diff
@@ -0,0 +1,152 @@
+Index: ps.c
+===================================================================
+RCS file: /cvs/gnome/ggv/src/ps.c,v
+retrieving revision 1.12
+retrieving revision 1.13
+diff -u -r1.12 -r1.13
+--- src/ps.c 19 Jun 2002 16:56:05 -0000 1.12
++++ src/ps.c 26 Sep 2002 22:27:53 -0000 1.13
+@@ -267,7 +267,7 @@
+
+ /* Jake Hamby patch 18/3/98 */
+
+- sscanf(line, "%*s %s", text);
++ sscanf(line, "%*s %256s", text);
+ /*doc->epsf = iscomment(text, "EPSF-");*/
+ doc->epsf = iscomment(text, "EPSF"); /* Hamby - This line changed */
+ doc->beginheader = position;
+@@ -308,7 +308,7 @@
+ } else if (doc->date == NULL && iscomment(line+2, "CreationDate:")) {
+ doc->date = gettextline(line+length("%%CreationDate:"));
+ } else if (bb_set == NONE && iscomment(line+2, "BoundingBox:")) {
+- sscanf(line+length("%%BoundingBox:"), "%s", text);
++ sscanf(line+length("%%BoundingBox:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ bb_set = ATEND;
+ } else {
+@@ -340,7 +340,7 @@
+ }
+ } else if (orientation_set == NONE &&
+ iscomment(line+2, "Orientation:")) {
+- sscanf(line+length("%%Orientation:"), "%s", text);
++ sscanf(line+length("%%Orientation:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ orientation_set = ATEND;
+ } else if (strcmp(text, "Portrait") == 0) {
+@@ -355,7 +355,7 @@
+ orientation_set = 1;
+ }
+ } else if (page_order_set == NONE && iscomment(line+2, "PageOrder:")) {
+- sscanf(line+length("%%PageOrder:"), "%s", text);
++ sscanf(line+length("%%PageOrder:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ page_order_set = ATEND;
+ } else if (strcmp(text, "Ascend") == 0) {
+@@ -369,7 +369,7 @@
+ page_order_set = 1;
+ }
+ } else if (pages_set == NONE && iscomment(line+2, "Pages:")) {
+- sscanf(line+length("%%Pages:"), "%s", text);
++ sscanf(line+length("%%Pages:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ pages_set = ATEND;
+ } else {
+@@ -568,7 +568,7 @@
+ /* Do nothing */
+ } else if (doc->default_page_orientation == NONE &&
+ iscomment(line+2, "PageOrientation:")) {
+- sscanf(line+length("%%PageOrientation:"), "%s", text);
++ sscanf(line+length("%%PageOrientation:"), "%256s", text);
+ if (strcmp(text, "Portrait") == 0) {
+ doc->default_page_orientation = GTK_GS_ORIENTATION_PORTRAIT;
+ } else if (strcmp(text, "Landscape") == 0) {
+@@ -695,7 +695,7 @@
+ /* Do nothing */
+ } else if (doc->default_page_orientation == NONE &&
+ iscomment(line+2, "PageOrientation:")) {
+- sscanf(line+length("%%PageOrientation:"), "%s", text);
++ sscanf(line+length("%%PageOrientation:"), "%256s", text);
+ if (strcmp(text, "Portrait") == 0) {
+ doc->default_page_orientation = GTK_GS_ORIENTATION_PORTRAIT;
+ } else if (strcmp(text, "Landscape") == 0) {
+@@ -837,7 +837,7 @@
+ /* Do nothing */
+ } else if (doc->pages[doc->numpages].orientation == NONE &&
+ iscomment(line+2, "PageOrientation:")) {
+- sscanf(line+length("%%PageOrientation:"), "%s", text);
++ sscanf(line+length("%%PageOrientation:"), "%256s", text);
+ if (strcmp(text, "Portrait") == 0) {
+ doc->pages[doc->numpages].orientation = GTK_GS_ORIENTATION_PORTRAIT;
+ } else if (strcmp(text, "Landscape") == 0) {
+@@ -872,7 +872,7 @@
+ g_free(cp);
+ } else if ((page_bb_set == NONE || page_bb_set == ATEND) &&
+ iscomment(line+2, "PageBoundingBox:")) {
+- sscanf(line+length("%%PageBoundingBox:"), "%s", text);
++ sscanf(line+length("%%PageBoundingBox:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ page_bb_set = ATEND;
+ } else {
+@@ -986,7 +986,7 @@
+ }
+ } else if (orientation_set == ATEND &&
+ iscomment(line+2, "Orientation:")) {
+- sscanf(line+length("%%Orientation:"), "%s", text);
++ sscanf(line+length("%%Orientation:"), "%256s", text);
+ if (strcmp(text, "Portrait") == 0) {
+ doc->orientation = GTK_GS_ORIENTATION_PORTRAIT;
+ } else if (strcmp(text, "Landscape") == 0) {
+@@ -996,7 +996,7 @@
+ doc->orientation = GTK_GS_ORIENTATION_SEASCAPE;
+ }
+ } else if (page_order_set == ATEND && iscomment(line+2, "PageOrder:")) {
+- sscanf(line+length("%%PageOrder:"), "%s", text);
++ sscanf(line+length("%%PageOrder:"), "%256s", text);
+ if (strcmp(text, "Ascend") == 0) {
+ doc->pageorder = ASCEND;
+ } else if (strcmp(text, "Descend") == 0) {
+@@ -1278,7 +1278,7 @@
+ else if IS_BEGIN("Data:") {
+ text[0] = '\0';
+ strcpy(save, line+7);
+- if (sscanf(line+length("%%BeginData:"), "%d %*s %s", &num, text) >= 1) {
++ if (sscanf(line+length("%%BeginData:"), "%d %*s %256s", &num, text) >= 1) {
+ if (strcmp(text, "Lines") == 0) {
+ for (i=0; i < num; i++) {
+ cp = fgets(line, size, fp);
+@@ -1402,7 +1402,7 @@
+ } else if (iscomment(line+7, "Data:")) {
+ text[0] = '\0';
+ strcpy(save, line+7);
+- if (sscanf(line+length("%%BeginData:"), "%d %*s %s", &num, text) >= 1) {
++ if (sscanf(line+length("%%BeginData:"), "%d %*s %256s", &num, text) >= 1) {
+ if (strcmp(text, "Lines") == 0) {
+ for (i=0; i < num; i++) {
+ cp = fgets(line, size, fp);
+@@ -1477,7 +1477,7 @@
+ } else if (iscomment(line+7, "Data:")) {
+ text[0] = '\0';
+ if (sscanf(line+length("%%BeginData:"),
+- "%d %*s %s", &num, text) >= 1) {
++ "%d %*s %256s", &num, text) >= 1) {
+ if (strcmp(text, "Lines") == 0) {
+ for (i=0; i < num; i++) {
+ fgets(line, sizeof(line), from);
+@@ -1546,7 +1546,7 @@
+ } else if (iscomment(line+7, "Data:")) {
+ text[0] = '\0';
+ if (sscanf(line+length("%%BeginData:"),
+- "%d %*s %s", &num, text) >= 1) {
++ "%d %*s %256s", &num, text) >= 1) {
+ if (strcmp(text, "Lines") == 0) {
+ for (i=0; i < num; i++) {
+ fgets(line, sizeof line, from);
+@@ -1624,7 +1624,7 @@
+ g_free(comment);
+ continue;
+ }
+- sscanf(comment+length("%%Pages:"), "%s", text);
++ sscanf(comment+length("%%Pages:"), "%256s", text);
+ if (strcmp(text, "(atend)") == 0) {
+ gtk_gs_doc_sink_write(dest, comment, strlen(comment));
+ pages_atend = TRUE;
diff --git a/app-text/ggv/ggv-1.99.90-r1.ebuild b/app-text/ggv/ggv-1.99.90-r1.ebuild
new file mode 100644
index 000000000000..0fe8e33d5a5a
--- /dev/null
+++ b/app-text/ggv/ggv-1.99.90-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.99.90-r1.ebuild,v 1.1 2002/10/17 07:44:06 aliz Exp $
+
+IUSE="doc"
+
+inherit gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="your favourite PostScript previewer"
+SRC_URI="mirror://gnome/2.0.1/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+RDEPEND=">=x11-libs/gtk+-2.0.6
+ >=x11-libs/pango-1.0.4
+ >=dev-libs/glib-2.0.6
+ >=gnome-base/libbonoboui-2.0.3
+ >=gnome-base/libgnome-2.0.4
+ >=gnome-base/libgnomeui-2.0.5
+ >=gnome-base/ORBit2-2.4.1
+ >=gnome-base/libglade-2.0.1
+ app-text/ghostscript
+ >=dev-libs/popt-1.6"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+G2CONF="${G2CONF} --disable-install-schemas --enable-platform-gnome-2"
+DOC="AUTHORS COPYING ChangeL* INSTALL MAINTAINERS NEWS README* TODO*"