summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-03-25 17:13:26 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-03-25 17:13:26 +0000
commitb29c2000055bc5b3ebfefce2ae62862eb84f9dcb (patch)
treed1bf1d0e519707a6fdee827bb7e779e8ff642c1e /app-text
parentstable on amd64 (diff)
downloadgentoo-2-b29c2000055bc5b3ebfefce2ae62862eb84f9dcb.tar.gz
gentoo-2-b29c2000055bc5b3ebfefce2ae62862eb84f9dcb.tar.bz2
gentoo-2-b29c2000055bc5b3ebfefce2ae62862eb84f9dcb.zip
Fixed BUG #85654. Plugins are installed into lib32 now.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/acroread/ChangeLog7
-rw-r--r--app-text/acroread/acroread-5.10.ebuild6
-rw-r--r--app-text/acroread/acroread-7.0.ebuild6
3 files changed, 16 insertions, 3 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index f8b1f339e1e5..31636448b5b5 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/acroread
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.48 2005/03/18 09:43:20 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.49 2005/03/25 17:13:26 kugelfang Exp $
+
+ 25 Mar 2005; Danny van Dyk <kugelfang@gentoo.org> acroread-5.10.ebuild,
+ acroread-7.0.ebuild:
+ Acroread provides x86 binaries/plugins only. Set ABI to x86 to make sure the
+ plugins end up in lib32.
18 Mar 2005; Stefan Schweizer <genstef@gentoo.org> acroread-7.0.ebuild:
Fix plugin-installation thanks to Kevin Andre Vatn.
diff --git a/app-text/acroread/acroread-5.10.ebuild b/app-text/acroread/acroread-5.10.ebuild
index a34d186e9296..fccfec997b62 100644
--- a/app-text/acroread/acroread-5.10.ebuild
+++ b/app-text/acroread/acroread-5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-5.10.ebuild,v 1.5 2005/03/16 20:03:28 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-5.10.ebuild,v 1.6 2005/03/25 17:13:26 kugelfang Exp $
inherit nsplugins eutils
@@ -25,6 +25,10 @@ INSTALLDIR=/opt/Acrobat5
S="${WORKDIR}/installers"
+# x86 binary package, ABI=x86
+# Danny van Dyk <kugelfang@gentoo.org> 2005/03/25
+has_multilib_profile && ABI="x86"
+
pkg_setup() {
if ! use noplugin ; then
einfo
diff --git a/app-text/acroread/acroread-7.0.ebuild b/app-text/acroread/acroread-7.0.ebuild
index 1d69f4e3dedb..1c6d5485a306 100644
--- a/app-text/acroread/acroread-7.0.ebuild
+++ b/app-text/acroread/acroread-7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.ebuild,v 1.5 2005/03/18 09:43:20 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-7.0.ebuild,v 1.6 2005/03/25 17:13:26 kugelfang Exp $
inherit nsplugins eutils
@@ -23,6 +23,10 @@ INSTALLDIR=/opt/Acrobat7
S=${WORKDIR}/AdobeReader
+# x86 binary package, ABI=x86
+# Danny van Dyk <kugelfang@gentoo.org> 2005/03/25
+has_multilib_profile && ABI="x86"
+
src_unpack() {
unpack ${A}
cd ${S}