summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 05:06:19 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 05:06:19 +0000
commitb54d8208a6b8d877b154c5214bf4bfb2f5b62ca3 (patch)
tree80fb94324bc6f702bfa2e60061b8e6250010edd2 /app-text
parentDEPEND on virtual/yacc since bison is no longer in the system set, bug 378535 (diff)
downloadgentoo-2-b54d8208a6b8d877b154c5214bf4bfb2f5b62ca3.tar.gz
gentoo-2-b54d8208a6b8d877b154c5214bf4bfb2f5b62ca3.tar.bz2
gentoo-2-b54d8208a6b8d877b154c5214bf4bfb2f5b62ca3.zip
USE=static-libs support, bug 378221
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/ChangeLog5
-rw-r--r--app-text/enchant/enchant-1.6.0.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/app-text/enchant/ChangeLog b/app-text/enchant/ChangeLog
index aa14b31a7b7a..d50e41009125 100644
--- a/app-text/enchant/ChangeLog
+++ b/app-text/enchant/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/enchant
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.118 2011/04/16 19:47:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.119 2011/08/14 05:06:19 nirbheek Exp $
+
+ 14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> enchant-1.6.0.ebuild:
+ USE=static-libs support, bug 378221
16 Apr 2011; Ulrich Mueller <ulm@gentoo.org> enchant-1.6.0.ebuild:
Fix dependency on aspell, bug 363377.
diff --git a/app-text/enchant/enchant-1.6.0.ebuild b/app-text/enchant/enchant-1.6.0.ebuild
index 77b9498d5c64..25c06c454987 100644
--- a/app-text/enchant/enchant-1.6.0.ebuild
+++ b/app-text/enchant/enchant-1.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.6.0.ebuild,v 1.12 2011/04/16 19:47:30 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.6.0.ebuild,v 1.13 2011/08/14 05:06:19 nirbheek Exp $
EAPI="3"
inherit libtool confutils autotools
@@ -12,9 +12,9 @@ SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="aspell +hunspell zemberek"
+IUSE="aspell +hunspell static-libs zemberek"
-COMMON_DEPENDS=">=dev-libs/glib-2
+COMMON_DEPENDS="dev-libs/glib:2
aspell? ( app-text/aspell )
hunspell? ( >=app-text/hunspell-1.2.1 )
zemberek? ( dev-libs/dbus-glib )"
@@ -40,6 +40,7 @@ src_configure() {
econf $(use_enable aspell) \
$(use_enable hunspell myspell) \
$(use_with hunspell system-myspell) \
+ $(use_enable static-libs static) \
$(use_enable zemberek) \
--disable-ispell \
--with-myspell-dir="${EPREFIX}"/usr/share/myspell/
@@ -48,6 +49,11 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO
+
+ if ! use static-libs; then
+ # Remove useless .la files
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ fi
}
pkg_postinst() {