summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-03 07:46:32 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-03 07:46:32 +0000
commitb82ad4da1ec798d5656ddc726c11fdb849ad783a (patch)
treeae58239ae2118af9eb700eee2e83fdd9e7a1bcf4 /app-text
parentVersion Bump; fix problems with format-security, bug #521100 (diff)
downloadgentoo-2-b82ad4da1ec798d5656ddc726c11fdb849ad783a.tar.gz
gentoo-2-b82ad4da1ec798d5656ddc726c11fdb849ad783a.tar.bz2
gentoo-2-b82ad4da1ec798d5656ddc726c11fdb849ad783a.zip
fix problems with format-security, bug #521258
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/talkfilters/ChangeLog10
-rw-r--r--app-text/talkfilters/files/talkfilters-2.3.8-format-security.patch43
-rw-r--r--app-text/talkfilters/talkfilters-2.3.8-r1.ebuild24
3 files changed, 75 insertions, 2 deletions
diff --git a/app-text/talkfilters/ChangeLog b/app-text/talkfilters/ChangeLog
index 2b9bacd42502..9cb789353b24 100644
--- a/app-text/talkfilters/ChangeLog
+++ b/app-text/talkfilters/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/talkfilters
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/talkfilters/ChangeLog,v 1.34 2011/01/06 16:24:20 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/talkfilters/ChangeLog,v 1.35 2015/07/03 07:46:32 jlec Exp $
+
+*talkfilters-2.3.8-r1 (03 Jul 2015)
+
+ 03 Jul 2015; Justin Lecher <jlec@gentoo.org>
+ +files/talkfilters-2.3.8-format-security.patch, +talkfilters-2.3.8-r1.ebuild:
+ fix problems with format-security, bug #521258
06 Jan 2011; Justin Lecher <jlec@gentoo.org> talkfilters-2.3.8.ebuild:
Some Clean up
diff --git a/app-text/talkfilters/files/talkfilters-2.3.8-format-security.patch b/app-text/talkfilters/files/talkfilters-2.3.8-format-security.patch
new file mode 100644
index 000000000000..cf59574694a6
--- /dev/null
+++ b/app-text/talkfilters/files/talkfilters-2.3.8-format-security.patch
@@ -0,0 +1,43 @@
+ wrap.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/wrap.c b/wrap.c
+index 7c89dc8..745d1ec 100644
+--- a/wrap.c
++++ b/wrap.c
+@@ -105,7 +105,7 @@ int main(int argc, char **argv)
+ {
+ *wp = 0;
+ putchar('\n');
+- printf(wbuf);
++ printf("%s", wbuf);
+ putchar(c);
+ putchar('\n');
+ wp = wbuf, ll = wl = 0;
+@@ -123,7 +123,7 @@ int main(int argc, char **argv)
+ {
+ *wp = 0;
+ if(ll) putchar(' '), ll++;
+- printf(wbuf);
++ printf("%s", wbuf);
+ ll += wl;
+ wl = 0, wp = wbuf;
+ }
+@@ -131,7 +131,7 @@ int main(int argc, char **argv)
+ {
+ *wp = 0;
+ putchar('\n');
+- printf(wbuf);
++ printf("%s", wbuf);
+ ll = wl;
+ wl = 0, wp = wbuf;
+ }
+@@ -148,7 +148,7 @@ int main(int argc, char **argv)
+ if(ll) putchar(' ');
+ }
+ else putchar('\n');
+- printf(wbuf);
++ printf("%s", wbuf);
+ }
+ putchar('\n');
+ free(wbuf);
diff --git a/app-text/talkfilters/talkfilters-2.3.8-r1.ebuild b/app-text/talkfilters/talkfilters-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..ff6d1bf93101
--- /dev/null
+++ b/app-text/talkfilters/talkfilters-2.3.8-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/talkfilters/talkfilters-2.3.8-r1.ebuild,v 1.1 2015/07/03 07:46:32 jlec Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Convert ordinary English text into text that mimics a stereotyped or otherwise humorous dialect"
+HOMEPAGE="http://www.hyperrealm.com/talkfilters/talkfilters.html"
+SRC_URI="http://www.hyperrealm.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}