summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-03-29 14:03:25 +0000
committerMichael Weber <xmw@gentoo.org>2011-03-29 14:03:25 +0000
commitbedaa7de593ada7073dc6a4ff1667dd428866595 (patch)
tree4f69a7debd9f5fccb19a2b32b95d37e711116219 /app-text
parentStable for HPPA (bug #360465). (diff)
downloadgentoo-2-bedaa7de593ada7073dc6a4ff1667dd428866595.tar.gz
gentoo-2-bedaa7de593ada7073dc6a4ff1667dd428866595.tar.bz2
gentoo-2-bedaa7de593ada7073dc6a4ff1667dd428866595.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mupdf/ChangeLog9
-rw-r--r--app-text/mupdf/files/mupdf-0.8.15-buildsystem.patch24
-rw-r--r--app-text/mupdf/files/mupdf-0.8.15-zoom.patch57
-rw-r--r--app-text/mupdf/mupdf-0.8.15.ebuild61
4 files changed, 150 insertions, 1 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index f04edcc847ab..ae91d8841006 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.10 2011/02/20 10:26:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.11 2011/03/29 14:03:25 xmw Exp $
+
+*mupdf-0.8.15 (29 Mar 2011)
+
+ 29 Mar 2011; Michael Weber <xmw@gentoo.org> +mupdf-0.8.15.ebuild,
+ +files/mupdf-0.8.15-buildsystem.patch, +files/mupdf-0.8.15-zoom.patch:
+ Version bum, thanks to shark@bitchx.it for the hint on bug 360455, added
+ vanilla useflag to disable zoom-patch
20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
mupdf-0.7_p20110212.ebuild:
diff --git a/app-text/mupdf/files/mupdf-0.8.15-buildsystem.patch b/app-text/mupdf/files/mupdf-0.8.15-buildsystem.patch
new file mode 100644
index 000000000000..631cf67be90d
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-0.8.15-buildsystem.patch
@@ -0,0 +1,24 @@
+--- Makerules
++++ Makerules
+@@ -7,10 +7,10 @@
+ CFLAGS ?=
+ LDFLAGS ?=
+
+-CFLAGS += -Ifitz -Imupdf -Wall
++CFLAGS += -Ifitz -Imupdf
+
+ ifeq "$(build)" "debug"
+-CFLAGS += -pipe -g
++CFLAGS +=
+ endif
+
+ ifeq "$(build)" "profile"
+@@ -28,7 +28,7 @@
+
+ ifeq "$(OS)" "Linux"
+ SYS_FREETYPE_INC := `pkg-config --cflags freetype2`
+-X11LIBS := -lX11 -lXext
++X11LIBS := `pkg-config --libs x11 xext`
+ PDFVIEW_EXE = $(X11VIEW_EXE)
+ endif
+
diff --git a/app-text/mupdf/files/mupdf-0.8.15-zoom.patch b/app-text/mupdf/files/mupdf-0.8.15-zoom.patch
new file mode 100644
index 000000000000..ccb4a39f3429
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-0.8.15-zoom.patch
@@ -0,0 +1,57 @@
+--- mupdf-0.8.15.orig/apps/man/mupdf.1
++++ mupdf-0.8.15/apps/man/mupdf.1
+@@ -37,6 +37,15 @@
+ .B \+, \-
+ Zoom in or out.
+ .TP
++.B _
++Reset zoom to default (72dpi).
++.TP
++.B z
++Zoom page size to fit into the window frame.
++.TP
++.B Z
++Zoom page size to fill the window frame.
++.TP
+ .B w
+ Shrinkwrap window to fit the page.
+ .TP
+--- mupdf-0.8.15.orig/apps/pdfapp.c
++++ mupdf-0.8.15/apps/pdfapp.c
+@@ -661,6 +661,20 @@
+ pdfapp_showpage(app, 0, 1, 1);
+ break;
+
++ case '_': // zoom to default resolution
++ app->resolution = 72;
++ pdfapp_showpage(app, 0, 1, 1);
++ break;
++
++ case 'z': // zoom to fit window
++ case 'Z': // zoom to fill window
++ if ( ( c == 'Z' ) ^ ( app->image->w * app->winh > app->winw * app->image->h ) )
++ app->resolution = ( app->resolution * app->winw ) / app->image->w;
++ else
++ app->resolution = ( app->resolution * app->winh ) / app->image->h;
++ pdfapp_showpage(app, 0, 1, 1);
++ break;
++
+ case 'L':
+ app->rotate -= 90;
+ pdfapp_showpage(app, 0, 1, 1);
+@@ -784,6 +798,7 @@
+ break;
+
+ case 'b':
++ case '\b': //backspace
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno -= atoi(app->number);
+@@ -792,6 +807,7 @@
+ break;
+
+ case ' ':
++ case 'f':
+ panto = DONT_PAN;
+ if (app->numberlen > 0)
+ app->pageno += atoi(app->number);
diff --git a/app-text/mupdf/mupdf-0.8.15.ebuild b/app-text/mupdf/mupdf-0.8.15.ebuild
new file mode 100644
index 000000000000..7d5bbd860434
--- /dev/null
+++ b/app-text/mupdf/mupdf-0.8.15.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-0.8.15.ebuild,v 1.1 2011/03/29 14:03:25 xmw Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="http://mupdf.com/"
+SRC_URI="http://mupdf.com/download/${P}-source.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X vanilla"
+
+RDEPEND="media-libs/freetype:2
+ media-libs/jbig2dec
+ virtual/jpeg
+ media-libs/openjpeg
+ X? ( x11-libs/libX11
+ x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+
+ use vanilla || epatch "${FILESDIR}"/${P}-zoom.patch
+}
+
+src_compile() {
+ local my_pdfexe=
+ use X || my_pdfexe="PDFVIEW_EXE="
+
+ emake build=debug ${my_pdfexe} CC="$(tc-getCC)" verbose=true -j1 || die
+}
+
+src_install() {
+ emake build=debug ${my_pdfexe} prefix="${D}usr" \
+ LIBDIR="${D}usr/$(get_libdir)" verbose=true install || die
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins debian/mupdf.pc || die
+
+ if use X ; then
+ domenu debian/mupdf.desktop || die
+ doicon debian/mupdf.xpm || die
+ doman apps/man/mupdf.1 || die
+ fi
+ doman apps/man/pdf{clean,draw,show}.1 || die
+ dodoc README || die
+
+ # avoid collision with app-text/poppler-utils
+ mv "${D}"usr/bin/pdfinfo "${D}"usr/bin/mupdf_pdfinfo || die
+}
+
+pkg_postinst() {
+ elog "pdfinfo was renamed to mupdf_pdfinfo"
+}