summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-20 14:13:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-20 14:13:13 +0000
commitc1bdc4e4ac15c37c8d692277585e0ae59aa8d311 (patch)
tree1c92cd0daff080cc32b0a05aec91d0c0e7d2bfa1 /app-text
parentAdded missing python USE flag conditional in prepare phase, fixes compilation... (diff)
downloadgentoo-2-c1bdc4e4ac15c37c8d692277585e0ae59aa8d311.tar.gz
gentoo-2-c1bdc4e4ac15c37c8d692277585e0ae59aa8d311.tar.bz2
gentoo-2-c1bdc4e4ac15c37c8d692277585e0ae59aa8d311.zip
version bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gocr/ChangeLog9
-rw-r--r--app-text/gocr/gocr-0.50.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index 859c3ee876a6..a25f0ec02bcd 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gocr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.68 2012/09/02 04:27:33 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.69 2013/05/20 14:13:13 aballier Exp $
+
+*gocr-0.50 (20 May 2013)
+
+ 20 May 2013; Alexis Ballier <aballier@gentoo.org> +gocr-0.50.ebuild:
+ version bump
02 Sep 2012; Tim Harder <radhermit@gentoo.org> -gocr-0.45.ebuild,
-files/gocr-0.45-makefile.patch, -gocr-0.48.ebuild:
diff --git a/app-text/gocr/gocr-0.50.ebuild b/app-text/gocr/gocr-0.50.ebuild
new file mode 100644
index 000000000000..9207bd90fb13
--- /dev/null
+++ b/app-text/gocr/gocr-0.50.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.50.ebuild,v 1.1 2013/05/20 14:13:13 aballier Exp $
+
+EAPI=4
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc scanner tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}
+ tk? (
+ media-gfx/xli
+ scanner? ( media-gfx/xsane )
+ )"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes}
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS BUGS CREDITS HISTORY RE* TODO
+
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ dodoc doc/gocr.html doc/examples.txt doc/unicode.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}