summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-11-03 20:57:36 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-11-03 20:57:36 +0000
commitfbe2a0ac81706636fe270c8a3ea6b08f5442783d (patch)
tree8e6aa1a3a4632a9a2f075b649639049bec3c331a /app-text
parentAdded Bret Towe's sed statements to produce an optimized build. Fixes #6756 (diff)
downloadgentoo-2-fbe2a0ac81706636fe270c8a3ea6b08f5442783d.tar.gz
gentoo-2-fbe2a0ac81706636fe270c8a3ea6b08f5442783d.tar.bz2
gentoo-2-fbe2a0ac81706636fe270c8a3ea6b08f5442783d.zip
Added Bret Towe's sed statements to optimize the package. Fixes #7038
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostview/ChangeLog8
-rw-r--r--app-text/ghostview/files/digest-ghostview-1.5-r11
-rw-r--r--app-text/ghostview/ghostview-1.5-r1.ebuild41
3 files changed, 49 insertions, 1 deletions
diff --git a/app-text/ghostview/ChangeLog b/app-text/ghostview/ChangeLog
index 80101f9e973e..55dc6143c1cf 100644
--- a/app-text/ghostview/ChangeLog
+++ b/app-text/ghostview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ghostview
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostview/ChangeLog,v 1.3 2002/08/14 10:31:35 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostview/ChangeLog,v 1.4 2002/11/03 20:57:36 rphillips Exp $
+
+*ghostview-1.5-r1 (03 Nov 2002)
+
+ 03 Nov 2002; Ryan Phillips <rphillips@gentoo.org> :
+
+ Added Bret Towe's sed statements for optimizing the package. Fixes #7038
*ghostview-1.5 (1 Feb 2002)
diff --git a/app-text/ghostview/files/digest-ghostview-1.5-r1 b/app-text/ghostview/files/digest-ghostview-1.5-r1
new file mode 100644
index 000000000000..d73ab66f9d4c
--- /dev/null
+++ b/app-text/ghostview/files/digest-ghostview-1.5-r1
@@ -0,0 +1 @@
+MD5 4f5c1bced73fe14b03109cfa7aacfd90 ghostview-1.5.tar.gz 139742
diff --git a/app-text/ghostview/ghostview-1.5-r1.ebuild b/app-text/ghostview/ghostview-1.5-r1.ebuild
new file mode 100644
index 000000000000..b5c2d1347c06
--- /dev/null
+++ b/app-text/ghostview/ghostview-1.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostview/ghostview-1.5-r1.ebuild,v 1.1 2002/11/03 20:57:36 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A PostScript viewer for X11"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ghostview/"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+RDEPEND="${DEPEND}
+ >=app-text/ghostscript-6.50-r2"
+
+src_unpack() {
+ unpack ${A}
+ # This patch contains all the Debian patches and enables anti-aliasing.
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ PATH=/usr/X11R6/bin:${PATH} # root doesn't get this by default
+ xmkmf -a || die
+ cp Makefile Makefile.old
+ sed -e "s:CDEBUGFLAGS = .*:CDEBUGFLAGS = ${CFLAGS} -fno-strength-reduce:" \
+ -e "s,all:: ghostview.\$(MANSUFFIX).html,all:: ,g" \
+ Makefile.old > Makefile
+ emake || die
+}
+
+src_install() {
+ dobin ghostview
+ newman ghostview.man ghostview.1
+ insinto /etc/X11/app-defaults
+ newins Ghostview.ad Ghostview
+ dodoc COPYING HISTORY README comments.doc
+}