summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-25 22:36:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-25 22:36:06 +0000
commit431412ce0a828b9377ecd79b80ef90a2737634df (patch)
tree54ccc91362bbf25769c3de8f325eb8486745e74a /app-vim/automatictexplugin
parentNew package, ebuild written by me (diff)
downloadgentoo-2-431412ce0a828b9377ecd79b80ef90a2737634df.tar.gz
gentoo-2-431412ce0a828b9377ecd79b80ef90a2737634df.tar.bz2
gentoo-2-431412ce0a828b9377ecd79b80ef90a2737634df.zip
Version bump.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/automatictexplugin')
-rw-r--r--app-vim/automatictexplugin/ChangeLog8
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-10.6.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index 754e998ba3ef..d53c62587988 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/automatictexplugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.13 2011/09/14 22:46:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.14 2011/09/25 22:36:06 radhermit Exp $
+
+*automatictexplugin-10.6 (25 Sep 2011)
+
+ 25 Sep 2011; Tim Harder <radhermit@gentoo.org>
+ +automatictexplugin-10.6.ebuild:
+ Version bump.
*automatictexplugin-10.5 (14 Sep 2011)
diff --git a/app-vim/automatictexplugin/automatictexplugin-10.6.ebuild b/app-vim/automatictexplugin/automatictexplugin-10.6.ebuild
new file mode 100644
index 000000000000..5de02a046e62
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-10.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-10.6.ebuild,v 1.1 2011/09/25 22:36:06 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"