summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-15 18:48:09 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-15 18:48:09 +0000
commit1b99a39ffb425234418f95d74921f3fb588cb61d (patch)
tree83b37207434decd872fe26730e7b0db5dcc0680f /app-vim/cctree
parentapp-crypt/truecrypt: Revbump. Remove dependency on a pkcs11 implementation. P... (diff)
downloadgentoo-2-1b99a39ffb425234418f95d74921f3fb588cb61d.tar.gz
gentoo-2-1b99a39ffb425234418f95d74921f3fb588cb61d.tar.bz2
gentoo-2-1b99a39ffb425234418f95d74921f3fb588cb61d.zip
Version bump.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/ChangeLog7
-rw-r--r--app-vim/cctree/cctree-1.60.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-vim/cctree/ChangeLog b/app-vim/cctree/ChangeLog
index 7bc98d7a1551..57dbeb529a37 100644
--- a/app-vim/cctree/ChangeLog
+++ b/app-vim/cctree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/cctree
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.3 2011/06/25 09:17:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.4 2011/07/15 18:48:09 radhermit Exp $
+
+*cctree-1.60 (15 Jul 2011)
+
+ 15 Jul 2011; Tim Harder <radhermit@gentoo.org> +cctree-1.60.ebuild:
+ Version bump.
*cctree-1.55 (25 Jun 2011)
diff --git a/app-vim/cctree/cctree-1.60.ebuild b/app-vim/cctree/cctree-1.60.ebuild
new file mode 100644
index 000000000000..0b92e9d0af69
--- /dev/null
+++ b/app-vim/cctree/cctree-1.60.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/cctree-1.60.ebuild,v 1.1 2011/07/15 18:48:09 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="CCTree"
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="http://sites.google.com/site/vimcctree/"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="cctree.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/cctree.vim > doc/cctree.txt
+
+ rm README
+}