summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-11 10:07:34 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-11 10:07:34 +0000
commita4fcdc524a6e182e72c5074555fd167dca447815 (patch)
tree83a5ae377ebd9f5b72747e030ff31aecb28ae1a2 /app-vim/latexsuite
parentRevbump to fix bug 343943, Updated SRC_URI/HOMEPAGE. (diff)
downloadgentoo-2-a4fcdc524a6e182e72c5074555fd167dca447815.tar.gz
gentoo-2-a4fcdc524a6e182e72c5074555fd167dca447815.tar.bz2
gentoo-2-a4fcdc524a6e182e72c5074555fd167dca447815.zip
Version bump. Add html USE flag to optionally install the extra HTML documentation.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/latexsuite')
-rw-r--r--app-vim/latexsuite/ChangeLog9
-rw-r--r--app-vim/latexsuite/latexsuite-1.8.23.20101027.ebuild56
-rw-r--r--app-vim/latexsuite/metadata.xml3
3 files changed, 67 insertions, 1 deletions
diff --git a/app-vim/latexsuite/ChangeLog b/app-vim/latexsuite/ChangeLog
index 392bd6604d5f..6a676e4acc2e 100644
--- a/app-vim/latexsuite/ChangeLog
+++ b/app-vim/latexsuite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/latexsuite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/latexsuite/ChangeLog,v 1.39 2010/11/01 15:31:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/latexsuite/ChangeLog,v 1.40 2010/11/11 10:07:34 radhermit Exp $
+
+*latexsuite-1.8.23.20101027 (11 Nov 2010)
+
+ 11 Nov 2010; Tim Harder <radhermit@gentoo.org>
+ +latexsuite-1.8.23.20101027.ebuild, metadata.xml:
+ Version bump. Add html USE flag to optionally install the extra HTML
+ documentation.
01 Nov 2010; Christian Faulhammer <fauli@gentoo.org>
latexsuite-1.8.23.20100129.ebuild:
diff --git a/app-vim/latexsuite/latexsuite-1.8.23.20101027.ebuild b/app-vim/latexsuite/latexsuite-1.8.23.20101027.ebuild
new file mode 100644
index 000000000000..bba924dd40da
--- /dev/null
+++ b/app-vim/latexsuite/latexsuite-1.8.23.20101027.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/latexsuite/latexsuite-1.8.23.20101027.ebuild,v 1.1 2010/11/11 10:07:34 radhermit Exp $
+
+EAPI=3
+
+inherit vim-plugin versionator
+
+MY_REV="1112"
+MY_PN="vim-latex"
+MY_P="${MY_PN}-$( replace_version_separator 3 - )-r${MY_REV}"
+
+DESCRIPTION="vim plugin: a comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="html"
+
+RDEPEND="virtual/latex-base"
+
+S="${WORKDIR}/${MY_P}"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_prepare() {
+ # The makefiles do weird stuff, including running the svn command
+ rm Makefile Makefile.in || die "rm Makefile Makefile.in failed"
+}
+
+src_install() {
+ use html && dohtml -r doc/
+
+ # Don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # Don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ elog
+ elog "To use the latexSuite plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ elog
+}
diff --git a/app-vim/latexsuite/metadata.xml b/app-vim/latexsuite/metadata.xml
index 8b8eb04bb758..0d0a29249a62 100644
--- a/app-vim/latexsuite/metadata.xml
+++ b/app-vim/latexsuite/metadata.xml
@@ -8,4 +8,7 @@
developer) on any bugs related to this package as he knows more
about it than me.</description>
</maintainer>
+ <use>
+ <flag name="html">Install HTML documentation</flag>
+ </use>
</pkgmetadata>