summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-02-09 01:05:45 +0000
committerTim Harder <radhermit@gentoo.org>2015-02-09 01:05:45 +0000
commit03902597b031b9efce743345b12d8d884491f226 (patch)
tree64f49b0142b134ebae63fdd210ed1f00342e4396 /app-vim
parentUpdate live ebuild with widevine change. (diff)
downloadgentoo-2-03902597b031b9efce743345b12d8d884491f226.tar.gz
gentoo-2-03902597b031b9efce743345b12d8d884491f226.tar.bz2
gentoo-2-03902597b031b9efce743345b12d8d884491f226.zip
Run tests and don't install test file (bug #535790).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimcalc/ChangeLog7
-rw-r--r--app-vim/vimcalc/vimcalc-1.3-r2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-vim/vimcalc/ChangeLog b/app-vim/vimcalc/ChangeLog
index 322d4abdbfbf..a42f071149c3 100644
--- a/app-vim/vimcalc/ChangeLog
+++ b/app-vim/vimcalc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vimcalc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcalc/ChangeLog,v 1.5 2015/01/06 13:04:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcalc/ChangeLog,v 1.6 2015/02/09 01:05:45 radhermit Exp $
+
+*vimcalc-1.3-r2 (09 Feb 2015)
+
+ 09 Feb 2015; Tim Harder <radhermit@gentoo.org> +vimcalc-1.3-r2.ebuild:
+ Run tests and don't install test file (bug #535790).
*vimcalc-1.3-r1 (06 Jan 2015)
diff --git a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
new file mode 100644
index 000000000000..2b88d7a098cd
--- /dev/null
+++ b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcalc/vimcalc-1.3-r2.ebuild,v 1.1 2015/02/09 01:05:45 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: provides an interactive calculator inside vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3329"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=15317 -> ${P}.zip"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="vimcalc"
+
+DEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ # Remove .DS_Store files that should not be installed
+ find -type f -name '.DS*' -delete
+}
+
+src_test() {
+ cd plugin || die
+ "${PYTHON}" tests.py || die "Tests failed"
+ rm tests.py || die
+}