summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-16 16:51:10 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-16 16:51:10 +0000
commit4f11a7955aa7cbb7686c4e6ce7ab669e3833e7e8 (patch)
tree2c8bc28ab214af92dba5c3e3033e8bd7ad3bd1bb /app-vim
parentsource is not POSIX compliant so use the dot instead, thanks to Martin Väth ... (diff)
downloadgentoo-2-4f11a7955aa7cbb7686c4e6ce7ab669e3833e7e8.tar.gz
gentoo-2-4f11a7955aa7cbb7686c4e6ce7ab669e3833e7e8.tar.bz2
gentoo-2-4f11a7955aa7cbb7686c4e6ce7ab669e3833e7e8.zip
Version bump.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vcscommand/ChangeLog8
-rw-r--r--app-vim/vcscommand/vcscommand-0.1_beta28.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/app-vim/vcscommand/ChangeLog b/app-vim/vcscommand/ChangeLog
index f4ac4ac0a3a5..f40692913fa8 100644
--- a/app-vim/vcscommand/ChangeLog
+++ b/app-vim/vcscommand/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vcscommand
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/ChangeLog,v 1.5 2008/09/20 15:43:20 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/ChangeLog,v 1.6 2008/10/16 16:51:10 hawking Exp $
+
+*vcscommand-0.1_beta28 (16 Oct 2008)
+
+ 16 Oct 2008; Ali Polatel <hawking@gentoo.org>
+ +vcscommand-0.1_beta28.ebuild:
+ Version bump.
*vcscommand-0.1_beta27 (20 Sep 2008)
diff --git a/app-vim/vcscommand/vcscommand-0.1_beta28.ebuild b/app-vim/vcscommand/vcscommand-0.1_beta28.ebuild
new file mode 100644
index 000000000000..5bdc1e65a1e8
--- /dev/null
+++ b/app-vim/vcscommand/vcscommand-0.1_beta28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/vcscommand-0.1_beta28.ebuild,v 1.1 2008/10/16 16:51:10 hawking Exp $
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: CVS/SVN/SVK integration plugin"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=90"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="cvs git subversion svk"
+
+RDEPEND="cvs? ( dev-util/cvs )
+ git? ( dev-util/git )
+ subversion? ( dev-util/subversion )
+ svk? ( dev-util/svk )
+ !app-vim/cvscommand
+ !app-vim/calendar" # conflict, bug 62677
+
+VIM_PLUGIN_HELPFILES="vcscommand"
+
+no_flags_die() {
+ eerror "Please choose at least one VCS system"
+ eerror "to be supported by this plugin."
+ die "No vcs systems set"
+}
+
+pkg_setup() {
+ elog "Note: Support for all VCS systems are enabled by use flags."
+ elog " Make sure you've enabled the flags you want."
+
+ use cvs || use git || use subversion || use svk || no_flags_die
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use cvs || rm syntax/CVSAnnotate.vim plugin/vcscvs.vim
+ use git || rm plugin/vcsgit.vim
+ use subversion || rm syntax/SVNAnnotate.vim plugin/vcssvn.vim
+ use svk || rm syntax/SVKAnnotate.vim plugin/vcssvk.vim
+}