summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-02-16 16:58:14 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-02-16 16:58:14 +0000
commit760159491f8a0f82ba99a82700b47b88913cc0a7 (patch)
treeb7b59231ca1e3d3656c28add3157e0d1d620bd9f /app-vim
parentMarked ~ppc/~ppc64 for bug #304365. (diff)
downloadgentoo-2-760159491f8a0f82ba99a82700b47b88913cc0a7.tar.gz
gentoo-2-760159491f8a0f82ba99a82700b47b88913cc0a7.tar.bz2
gentoo-2-760159491f8a0f82ba99a82700b47b88913cc0a7.zip
minor, minor bump to fix the EXPORT_FUNCTIONS highlighting and defaults to EAPI=3
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog9
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20100215.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index 0f358bc2f990..24c3c17c6164 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.106 2010/02/15 20:44:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.107 2010/02/16 16:58:14 darkside Exp $
+
+*gentoo-syntax-20100215 (16 Feb 2010)
+
+ 16 Feb 2010; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-syntax-20100215.ebuild:
+ minor, minor bump to fix the EXPORT_FUNCTIONS highlighting and defaults to
+ EAPI=3
15 Feb 2010; Joseph Jezak <josejx@gentoo.org>
gentoo-syntax-20090720.ebuild:
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20100215.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20100215.ebuild
new file mode 100644
index 000000000000..8769ce1cb3ec
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20100215.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20100215.ebuild,v 1.1 2010/02/16 16:58:14 darkside Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentooexperimental.org/~darkside/distfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ echo
+}