summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-06 13:02:41 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-06 13:02:41 +0000
commit7a42dc1a1e42f7164bb08f7f44697d8e1165734d (patch)
treea0efe455c03e2ba70c45e016d46edc31b73e7d47 /app-vim
parentinitial commit of josm (diff)
downloadgentoo-2-7a42dc1a1e42f7164bb08f7f44697d8e1165734d.tar.gz
gentoo-2-7a42dc1a1e42f7164bb08f7f44697d8e1165734d.tar.bz2
gentoo-2-7a42dc1a1e42f7164bb08f7f44697d8e1165734d.zip
version bump
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vcscommand/ChangeLog8
-rw-r--r--app-vim/vcscommand/files/digest-vcscommand-0.1_beta193
-rw-r--r--app-vim/vcscommand/vcscommand-0.1_beta19.ebuild43
3 files changed, 53 insertions, 1 deletions
diff --git a/app-vim/vcscommand/ChangeLog b/app-vim/vcscommand/ChangeLog
index 2a54ae171a4a..95834314cfee 100644
--- a/app-vim/vcscommand/ChangeLog
+++ b/app-vim/vcscommand/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vcscommand
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/ChangeLog,v 1.1 2007/05/08 05:12:50 pioto Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/ChangeLog,v 1.2 2007/09/06 13:02:41 hawking Exp $
+
+*vcscommand-0.1_beta19 (06 Sep 2007)
+
+ 06 Sep 2007; Ali Polatel <hawking@gentoo.org>
+ +vcscommand-0.1_beta19.ebuild:
+ Version bump.
*vcscommand-0.1_beta16 (08 May 2007)
diff --git a/app-vim/vcscommand/files/digest-vcscommand-0.1_beta19 b/app-vim/vcscommand/files/digest-vcscommand-0.1_beta19
new file mode 100644
index 000000000000..074d920d9a33
--- /dev/null
+++ b/app-vim/vcscommand/files/digest-vcscommand-0.1_beta19
@@ -0,0 +1,3 @@
+MD5 1de306836b4e8ef219bea447dae081ca vcscommand-0.1_beta19.tar.bz2 21919
+RMD160 d5d292c6ed697a4cac72467c68193a034526fb62 vcscommand-0.1_beta19.tar.bz2 21919
+SHA256 0ea802b2ee7349d6d52fdac006a2edf24d0873cecfeb104577ebc0c25f39a54c vcscommand-0.1_beta19.tar.bz2 21919
diff --git a/app-vim/vcscommand/vcscommand-0.1_beta19.ebuild b/app-vim/vcscommand/vcscommand-0.1_beta19.ebuild
new file mode 100644
index 000000000000..5664f1e5aece
--- /dev/null
+++ b/app-vim/vcscommand/vcscommand-0.1_beta19.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vcscommand/vcscommand-0.1_beta19.ebuild,v 1.1 2007/09/06 13:02:41 hawking Exp $
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: CVS/SVN/SVK integration plugin"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=90"
+
+LICENSE="public-domain"
+KEYWORDS="~x86"
+IUSE="cvs subversion svk"
+
+RDEPEND="cvs? ( dev-util/cvs )
+ subversion? ( dev-util/subversion )
+ svk? ( dev-util/svk )
+ !app-vim/cvscommand
+ !app-vim/calendar" # conflict, bug 62677
+
+VIM_PLUGIN_HELPFILES="vcscommand"
+
+no_flags_die() {
+ eerror "Please choose at least one VCS system"
+ eerror "to be supported by this plugin."
+ die "No vcs systems set"
+}
+
+pkg_setup() {
+ elog "Note: Support for all VCS systems are enabled by use flags."
+ elog " Make sure you've enabled the flags you want."
+
+ use cvs || use subversion || use svk || no_flags_die
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use cvs || rm syntax/CVSAnnotate.vim plugin/vcscvs.vim
+ use subversion || rm syntax/SVNAnnotate.vim plugin/vcssvn.vim
+ use svk || rm syntax/SVKAnnotate.vim plugin/vcssvk.vim
+}