summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-04-23 18:55:10 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-04-23 18:55:10 +0000
commitff113ca896f3156c65d03c4f3f120b873a7ce251 (patch)
tree48b9d6a169259251af46f29e4318268da093913b /dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild
parentmark stable (diff)
downloadgentoo-2-ff113ca896f3156c65d03c4f3f120b873a7ce251.tar.gz
gentoo-2-ff113ca896f3156c65d03c4f3f120b873a7ce251.tar.bz2
gentoo-2-ff113ca896f3156c65d03c4f3f120b873a7ce251.zip
Version bump for bug 89694; added dosed to all src_installs correcting cflags in pkgconfig file for bug 83794.
(Portage version: 2.0.51.20)
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild b/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild
index 12fd0bc69e1b..fa8793efb224 100644
--- a/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild,v 1.2 2005/04/01 17:15:54 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-1.0.4-r2.ebuild,v 1.3 2005/04/23 18:55:09 ka0ttic Exp $
-IUSE=""
-
-inherit libtool eutils
-
-MY_P=${P/pp/++}
+inherit libtool multilib
+MY_P="${P/pp/++}"
DESCRIPTION="C++ wrapper for the libxml XML parser library"
HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
@@ -15,6 +12,7 @@ SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
RDEPEND=">=dev-libs/libxml2-2.5.8
>=sys-devel/automake-1.7
@@ -23,22 +21,12 @@ RDEPEND=">=dev-libs/libxml2-2.5.8
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
MAKEOPTS="${MAKEOPTS} -j1"
-src_unpack() {
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.7
- unpack "${A}"
- cd "${S}"
- epatch ${FILESDIR}/${P}-pc.patch # closes Bug 83794
- aclocal && autoconf && automake -a && \
- libtoolize --force --copy || die
- econf || die "Configure failed."
- emake || die "Make failed."
-}
-
src_install() {
make DESTDIR="${D}" install || die "Install failed"
+ dosed -i 's|^\(Cflags.*-I.* \)-I.*$|\1|' \
+ /usr/$(get_libdir)/pkgconfig/${MY_P%.*}.pc
dodoc AUTHORS ChangeLog NEWS README*
}