summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2014-12-06 21:15:22 +0000
committerMatthias Maier <tamiko@gentoo.org>2014-12-06 21:15:22 +0000
commit27cb32d0a33abda2ff686f3d3902cbf58d79cba1 (patch)
treed432d8ed4a06e201b815ab5b3ae77da59527abe7 /dev-cpp
parentdrop python-r1 eclass; fix dependencies; fix llvm configuration wrt bug #531316 (diff)
downloadgentoo-2-27cb32d0a33abda2ff686f3d3902cbf58d79cba1.tar.gz
gentoo-2-27cb32d0a33abda2ff686f3d3902cbf58d79cba1.tar.bz2
gentoo-2-27cb32d0a33abda2ff686f3d3902cbf58d79cba1.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/ChangeLog7
-rw-r--r--dev-cpp/tbb/tbb-4.3.20141023.ebuild127
2 files changed, 133 insertions, 1 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index fa4115409793..83ef1136419c 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.48 2014/10/30 14:39:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.49 2014/12/06 21:15:22 tamiko Exp $
+
+*tbb-4.3.20141023 (06 Dec 2014)
+
+ 06 Dec 2014; Matthias Maier <tamiko@gentoo.org> +tbb-4.3.20141023.ebuild:
+ version bump
30 Oct 2014; Alexis Ballier <aballier@gentoo.org> tbb-4.2.20140122.ebuild:
keyword ~arm
diff --git a/dev-cpp/tbb/tbb-4.3.20141023.ebuild b/dev-cpp/tbb/tbb-4.3.20141023.ebuild
new file mode 100644
index 000000000000..3620a4ffdf9f
--- /dev/null
+++ b/dev-cpp/tbb/tbb-4.3.20141023.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.3.20141023.ebuild,v 1.1 2014/12/06 21:15:22 tamiko Exp $
+
+EAPI=5
+inherit eutils flag-o-matic multilib versionator toolchain-funcs
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug doc examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
+ # use fully qualified gcc compilers. do not force march/mcpu
+ # not tested with icc
+ # order in sed expressions is important
+ sed -i \
+ -e "s/g++/$(tc-getCXX)/g" \
+ -e "s/gcc/$(tc-getCC)/g" \
+ -e 's/-m\(arch\|cpu\)=*[[:space:]]//g' \
+ -e 's/-\(m\|-\)\(64\|32\)//g' \
+ -e 's/-O2/$(CXXFLAGS)/g' \
+ -e "/^ASM/s/as/$(tc-getAS)/g" \
+ build/*.gcc.inc || die
+
+ # Give it a soname on FreeBSD
+ echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
+ # Set proper versionning on FreeBSD
+ sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
+
+ # force 64bit where applicable, 32bit where applicable...
+ # built-in detection is based on running kernel, which messes up
+ # e.g. in a x86 chroot on amd64 kernel. Bug 462130
+ # see build/linux.inc for values
+ use amd64 && export arch=x86_64
+ use amd64-linux && export arch=x86_64
+ use x86 && export arch=ia32
+ use x86-linux && export arch=ia32
+ # no idea what to do with ppc but so far it seems to work
+
+ find include -name \*.html -delete || die
+
+ # pc files are for debian and fedora compatibility
+ # some deps use them
+ cat <<-EOF > ${PN}.pc.template
+ prefix=${EPREFIX}/usr
+ libdir=\${prefix}/$(get_libdir)
+ includedir=\${prefix}/include
+ Name: ${PN}
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Cflags: -I\${includedir}
+ EOF
+ cp ${PN}.pc.template ${PN}.pc
+ cat <<-EOF >> ${PN}.pc
+ Libs: -L\${libdir} -ltbb
+ Libs.private: -lm -lrt
+ EOF
+ cp ${PN}.pc.template ${PN}malloc.pc
+ cat <<-EOF >> ${PN}malloc.pc
+ Libs: -L\${libdir} -ltbbmalloc
+ Libs.private: -lm -lrt
+ EOF
+ cp ${PN}.pc.template ${PN}malloc_proxy.pc
+ cat <<-EOF >> ${PN}malloc_proxy.pc
+ Libs: -L\${libdir} -ltbbmalloc_proxy
+ Libs.private: -lrt
+ Requires: tbbmalloc
+ EOF
+ use debug || sed -i -e '/_debug/d' Makefile
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++* ]]; then
+ comp="gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ comp="icc"
+ else
+ die "compiler $(tc-getCXX) not supported by build system"
+ fi
+ emake compiler=${comp} tbb tbbmalloc
+}
+
+src_test() {
+ append-cxxflags -fabi-version=4
+ # avoid oversubscribing with -j1
+ emake -j1 compiler=${comp} test
+}
+
+src_install(){
+ local l
+ for l in $(find build -name lib\*.so.\*); do
+ dolib.so ${l}
+ local bl=$(basename ${l})
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ doheader -r include/*
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins *.pc
+
+ dodoc README CHANGES doc/Release_Notes.txt
+ use doc && dohtml -r doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples
+ fi
+}