summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-02 07:17:04 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-02 07:17:04 +0000
commit4504459c35f5b04012d9a3992bb584ff99a97724 (patch)
treed843908332a290863a11f96406a16eabef47e279 /dev-cpp
parentmarked x86 per bug 414305 (diff)
downloadgentoo-2-4504459c35f5b04012d9a3992bb584ff99a97724.tar.gz
gentoo-2-4504459c35f5b04012d9a3992bb584ff99a97724.tar.bz2
gentoo-2-4504459c35f5b04012d9a3992bb584ff99a97724.zip
Fix building with >=glib-2.31 (bug #414127, thanks to salamanderrake for reporting).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtksourceviewmm/ChangeLog7
-rw-r--r--dev-cpp/gtksourceviewmm/files/gtksourceviewmm-2.10.2-glib-2.31.patch45
-rw-r--r--dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild9
3 files changed, 57 insertions, 4 deletions
diff --git a/dev-cpp/gtksourceviewmm/ChangeLog b/dev-cpp/gtksourceviewmm/ChangeLog
index 82cfcb9f6eea..7ffe002d26c8 100644
--- a/dev-cpp/gtksourceviewmm/ChangeLog
+++ b/dev-cpp/gtksourceviewmm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gtksourceviewmm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtksourceviewmm/ChangeLog,v 1.23 2012/04/29 15:18:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtksourceviewmm/ChangeLog,v 1.24 2012/05/02 07:17:04 tetromino Exp $
+
+ 02 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gtksourceviewmm-2.10.2.ebuild, +files/gtksourceviewmm-2.10.2-glib-2.31.patch:
+ Fix building with >=glib-2.31 (bug #414127, thanks to salamanderrake for
+ reporting).
29 Apr 2012; Markus Meier <maekke@gentoo.org> gtksourceviewmm-3.2.0.ebuild:
x86 stable, bug #410611
diff --git a/dev-cpp/gtksourceviewmm/files/gtksourceviewmm-2.10.2-glib-2.31.patch b/dev-cpp/gtksourceviewmm/files/gtksourceviewmm-2.10.2-glib-2.31.patch
new file mode 100644
index 000000000000..b42d0727f106
--- /dev/null
+++ b/dev-cpp/gtksourceviewmm/files/gtksourceviewmm-2.10.2-glib-2.31.patch
@@ -0,0 +1,45 @@
+Fix build with glib 2.31
+
+Patch by Dominique Leuenberger <dimstar@opensuse.org>
+
+https://bugzilla.gnome.org/show_bug.cgi?id=666651
+
+Index: gtksourceviewmm-2.10.2/gtksourceview/gtksourceviewmm/sourceiter.cc
+===================================================================
+--- a/gtksourceviewmm-2.10.2/gtksourceview/gtksourceviewmm/sourceiter.cc
++++ b/gtksourceviewmm-2.10.2/gtksourceview/gtksourceviewmm/sourceiter.cc
+@@ -28,7 +28,7 @@
+ */
+
+ #include "sourceiter.h"
+-#include <glib/gmessages.h>
++#include <glib.h>
+ #include <gtksourceview/gtksourceview-typebuiltins.h>
+ namespace gtksourceview
+ {
+Index: gtksourceviewmm-2.10.2/gtksourceview/src/sourceiter.ccg
+===================================================================
+--- a/gtksourceviewmm-2.10.2/gtksourceview/src/sourceiter.ccg
++++ b/gtksourceviewmm-2.10.2/gtksourceview/src/sourceiter.ccg
+@@ -21,7 +21,7 @@
+ */
+
+ #include "sourceiter.h"
+-#include <glib/gmessages.h>
++#include <glib.h>
+ #include <gtksourceview/gtksourceview-typebuiltins.h>
+ namespace gtksourceview
+ {
+Index: gtksourceviewmm-2.10.2/tests/search/main.cc
+===================================================================
+--- a/gtksourceviewmm-2.10.2/tests/search/main.cc
++++ b/gtksourceviewmm-2.10.2/tests/search/main.cc
+@@ -6,7 +6,7 @@
+ #include <cstring>
+ #include <gtkmm.h>
+ #include <gtksourceviewmm.h>
+-#include <glib/gmessages.h>
++#include <glib.h>
+
+ using namespace std ;
+ using namespace Gtk;
diff --git a/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild b/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild
index a5b1f6bcafba..d20155c97367 100644
--- a/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild
+++ b/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild,v 1.6 2011/10/21 14:07:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtksourceviewmm/gtksourceviewmm-2.10.2.ebuild,v 1.7 2012/05/02 07:17:04 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="C++ bindings for gtksourceview"
HOMEPAGE="http://projects.gnome.org/gtksourceviewmm/"
@@ -33,6 +33,9 @@ pkg_setup() {
}
src_prepare() {
+ # bug #414127, https://bugzilla.gnome.org/show_bug.cgi?id=666651
+ epatch "${FILESDIR}/${P}-glib-2.31.patch"
+
gnome2_src_prepare
# Remove docs from SUBDIRS so that docs are not installed, as