summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-05-07 05:32:40 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-05-07 05:32:40 +0000
commit8027f171c59105877780543bbccc1a7e073602db (patch)
treeabbd9e49769613c92bd5b35e1a5575f4198e3ad6 /dev-cpp
parentKeyword for mips. (diff)
downloadgentoo-2-8027f171c59105877780543bbccc1a7e073602db.tar.gz
gentoo-2-8027f171c59105877780543bbccc1a7e073602db.tar.bz2
gentoo-2-8027f171c59105877780543bbccc1a7e073602db.zip
Fixed problem with autoconf-2.62 (bug #219192), had to update the gcc42_atomicity.patch for that as well. Version bump.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog11
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild7
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild72
-rw-r--r--dev-cpp/commoncpp2/files/1.6.1-autoconf.patch11
-rw-r--r--dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch42
-rw-r--r--dev-cpp/commoncpp2/files/1.6.2-autoconf.patch11
6 files changed, 123 insertions, 31 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 7a24d0e20f65..b633e27e1ad1 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.41 2008/03/04 07:31:37 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.42 2008/05/07 05:32:39 dev-zero Exp $
+
+*commoncpp2-1.6.2 (07 May 2008)
+
+ 07 May 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.6.1-autoconf.patch, +files/1.6.2-autoconf.patch,
+ files/1.6.1-gcc42_atomicity.patch, commoncpp2-1.6.1.ebuild,
+ +commoncpp2-1.6.2.ebuild:
+ Fixed problem with autoconf-2.62 (bug #219192), had to update the
+ gcc42_atomicity.patch for that as well. Version bump.
04 Mar 2008; Tiziano Müller <dev-zero@gentoo.org>
-files/1.5.7-as-needed.patch, -files/1.5.7-ssl_config.patch,
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild
index 685014930c0c..c634c42063e1 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild,v 1.6 2008/02/17 12:46:47 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.1.ebuild,v 1.7 2008/05/07 05:32:39 dev-zero Exp $
inherit eutils autotools
@@ -23,8 +23,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-gcc42_atomicity.patch"
- eautoconf
+ epatch "${FILESDIR}/${PV}-gcc42_atomicity.patch" \
+ "${FILESDIR}/${PV}-autoconf.patch"
+ AT_M4DIR="m4" eautoreconf
}
src_compile() {
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild
new file mode 100644
index 000000000000..2f9e5166bddd
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.2.ebuild,v 1.1 2008/05/07 05:32:39 dev-zero Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples ipv6 gnutls"
+
+RDEPEND="gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ sys-libs/zlib"
+DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch" \
+ "${FILESDIR}/${PV}-autoconf.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ use doc || \
+ sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
+
+ local myconf
+ use gnutls || myconf="--with-openssl"
+
+ econf \
+ $(use_enable debug) \
+ $(use_with ipv6 ) \
+ ${myconf} || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ cd demo
+ doins *.cpp *.h *.xml README
+ fi
+}
+
+pkg_postinst() {
+ ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
+ ewarn "run the following command to find broken packages and rebuild them:"
+ ewarn " revdep-rebuild --library=libccext2-1.5.so"
+}
+
+# Some of the tests hang forever
+#src_test() {
+# cd "${S}/tests"
+# emake || die "emake tests failed"
+# ./test.sh || die "tests failed"
+#}
diff --git a/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch
new file mode 100644
index 000000000000..b2befd567582
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.6.1-autoconf.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-05-06 10:41:53.000000000 +0200
++++ configure.ac 2008-05-06 10:42:19.000000000 +0200
+@@ -10,6 +10,8 @@
+
+ AC_INIT(src/thread.cpp)
+
++m4_pattern_allow([^LT_VERSION$])
++
+ VERSION="1.6.1"
+ LT_RELEASE="1.6"
+ LT_VERSION="0:1"
diff --git a/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch b/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch
index 423defe8f7ac..da30105f8cf4 100644
--- a/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch
+++ b/dev-cpp/commoncpp2/files/1.6.1-gcc42_atomicity.patch
@@ -1,31 +1,6 @@
-diff -Naur commoncpp2-1.6.1.orig/config.h.in commoncpp2-1.6.1/config.h.in
---- commoncpp2-1.6.1.orig/config.h.in 2007-12-24 09:45:11.000000000 +0100
-+++ commoncpp2-1.6.1/config.h.in 2007-12-24 10:25:43.000000000 +0100
-@@ -239,6 +239,9 @@
- /* Define to 1 if you have the <bits/atomicity.h> header file. */
- #undef HAVE_BITS_ATOMICITY_H
-
-+/* Define to 1 if you have the <ext/atomicity.h> header file. */
-+#undef HAVE_EXT_ATOMICITY_H
-+
- /* Define to 1 if you have the <bits/wordsize.h> header file. */
- #undef HAVE_BITS_WORDSIZE_H
-
-@@ -1088,7 +1091,11 @@
-
- #if defined(__cplusplus)
- #if defined(HAVE_GCC_BITS_ATOMIC) || defined(HAVE_GCC_CXX_BITS_ATOMIC)
-+#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
-+#include <ext/atomicity.h>
-+#else
- #include <bits/atomicity.h>
-+#endif
- #define HAVE_ATOMIC
- #endif
- #endif
diff -Naur commoncpp2-1.6.1.orig/m4/ost_pthread.m4 commoncpp2-1.6.1/m4/ost_pthread.m4
---- commoncpp2-1.6.1.orig/m4/ost_pthread.m4 2007-12-24 09:45:11.000000000 +0100
-+++ commoncpp2-1.6.1/m4/ost_pthread.m4 2007-12-24 10:12:24.000000000 +0100
+--- commoncpp2-1.6.1.orig/m4/ost_pthread.m4 2008-05-06 10:47:42.000000000 +0200
++++ commoncpp2-1.6.1/m4/ost_pthread.m4 2008-05-06 16:11:05.000000000 +0200
@@ -92,7 +92,9 @@
dnl check for gcc's bits/atomicity and the atomic functions therein
AC_CHECK_HEADERS([bits/atomicity.h],
@@ -73,3 +48,16 @@ diff -Naur commoncpp2-1.6.1.orig/m4/ost_pthread.m4 commoncpp2-1.6.1/m4/ost_pthre
AC_MSG_RESULT($ost_cv_gcc_cxx_atomic)
fi
+@@ -438,7 +458,11 @@
+
+ #if defined(__cplusplus)
+ #if defined(HAVE_GCC_BITS_ATOMIC) || defined(HAVE_GCC_CXX_BITS_ATOMIC)
+-#include <bits/atomicity.h>
++#if (__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 2))
++ #include <ext/atomicity.h>
++#else
++ #include <bits/atomicity.h>
++#endif
+ #define HAVE_ATOMIC
+ #endif
+ #endif
diff --git a/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch
new file mode 100644
index 000000000000..fcba56dccb4b
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.6.2-autoconf.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-05-06 10:41:53.000000000 +0200
++++ configure.ac 2008-05-06 10:42:19.000000000 +0200
+@@ -10,6 +10,8 @@
+
+ AC_INIT(src/thread.cpp)
+
++m4_pattern_allow([^LT_VERSION$])
++
+ VERSION="1.6.2"
+ LT_RELEASE="1.6"
+ LT_VERSION="0:2"