summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-01-10 13:37:49 +0000
committerJohannes Huber <johu@gentoo.org>2015-01-10 13:37:49 +0000
commit9925e37f538dfa08790550d96262c5069e6c16b8 (patch)
tree3cb003b1d3ec92e283aebf9f4551b3f7d97a0acd /dev-cpp
parentversion bump (diff)
downloadgentoo-2-9925e37f538dfa08790550d96262c5069e6c16b8.tar.gz
gentoo-2-9925e37f538dfa08790550d96262c5069e6c16b8.tar.bz2
gentoo-2-9925e37f538dfa08790550d96262c5069e6c16b8.zip
New package. Ebuild by Nikoli <nikoli@gmx.us>. Bug #528550.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/lucene++/ChangeLog12
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch13
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch42
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch39
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.6.ebuild39
-rw-r--r--dev-cpp/lucene++/metadata.xml12
6 files changed, 157 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/ChangeLog b/dev-cpp/lucene++/ChangeLog
new file mode 100644
index 000000000000..e0bed147a89e
--- /dev/null
+++ b/dev-cpp/lucene++/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-cpp/lucene++
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/lucene++/ChangeLog,v 1.1 2015/01/10 13:37:49 johu Exp $
+
+*lucene++-3.0.6 (10 Jan 2015)
+
+ 10 Jan 2015; Johannes Huber <johu@gentoo.org> +lucene++-3.0.6.ebuild,
+ +files/lucene++-3.0.6-disable-demos.patch,
+ +files/lucene++-3.0.6-disable-tests.patch,
+ +files/lucene++-3.0.6-fix-installing-headers.patch, +metadata.xml:
+ New package. Ebuild by Nikoli <nikoli@gmx.us>. Bug #528550.
+
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
new file mode 100644
index 000000000000..ba5deca413c8
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9217c21..d4e7b86 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -118,7 +118,7 @@ enable_testing()
+
+ add_subdirectory(src/core)
+ add_subdirectory(src/contrib)
+-add_subdirectory(src/demo)
++#add_subdirectory(src/demo)
+ add_subdirectory(src/test)
+
+ #################################
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
new file mode 100644
index 000000000000..1fae17e71d30
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
@@ -0,0 +1,42 @@
+Forwarded: https://github.com/luceneplusplus/LucenePlusPlus/pull/64
+Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Description: Disabling tests until we find a proper way for building and including gtest
+ In the next release this might become possible, after commit 83356d9681fb52
+ https://github.com/luceneplusplus/LucenePlusPlus/commit/83356d9681fb52a4c190d2cf033279006c1bf57d
+Last-Update: 2014-08-25
+--- a/CMakeExternal.txt
++++ b/CMakeExternal.txt
+@@ -1,5 +1,6 @@
+ # Enable ExternalProject CMake module
+ include(ExternalProject)
++find_package(Subversion REQUIRED)
+
+ # main directory for external projects
+ set_directory_properties(PROPERTIES EP_PREFIX ${CMAKE_CURRENT_BINARY_DIR}/ThirdParty)
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -49,7 +49,6 @@
+ # bootstrap
+ ####################################
+
+-find_package(Subversion REQUIRED)
+ find_package(Threads REQUIRED)
+ find_package(Boost COMPONENTS
+ date_time
+@@ -114,13 +113,13 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/include
+ )
+
+-include(CMakeExternal.txt)
+-enable_testing()
++#include(CMakeExternal.txt)
++#enable_testing()
+
+ add_subdirectory(src/core)
+ add_subdirectory(src/contrib)
+ #add_subdirectory(src/demo)
+-add_subdirectory(src/test)
++#add_subdirectory(src/test)
+
+ #################################
+ # install pkg-config file
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
new file mode 100644
index 000000000000..f9ccc84eccd3
--- /dev/null
+++ b/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
@@ -0,0 +1,39 @@
+From: rezso <rezso@example.com>
+Date: Mon, 19 May 2014 09:20:40 +0100
+Subject: [PATCH] fix installing lucene++ headers in 3.0.6
+
+Origin: upstream, https://github.com/luceneplusplus/LucenePlusPlus/commit/994f03cf736229044a168835ae7387696041658f
+Description: backport upstream patch to fix missing headers install
+
+Index: lucene++-3.0.6/CMakeLists.txt
+===================================================================
+--- lucene++-3.0.6.orig/CMakeLists.txt
++++ lucene++-3.0.6/CMakeLists.txt
+@@ -139,6 +139,14 @@ if(NOT WIN32)
+ DESTINATION ${LIB_DESTINATION}/pkgconfig)
+ endif()
+
++#################################
++# install Config.h
++#################################
++install(
++ FILES
++ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
++ DESTINATION include/lucene++)
++
+ ####################################
+ # custom targets
+ ####################################
+Index: lucene++-3.0.6/src/core/CMakeLists.txt
+===================================================================
+--- lucene++-3.0.6.orig/src/core/CMakeLists.txt
++++ lucene++-3.0.6/src/core/CMakeLists.txt
+@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_header
+ )
+
+ file(GLOB_RECURSE lucene_headers
+- include/*.h
++ "${lucene++_SOURCE_DIR}/include/*.h"
+ )
+
+ add_definitions(-DLPP_BUILDING_LIB)
diff --git a/dev-cpp/lucene++/lucene++-3.0.6.ebuild b/dev-cpp/lucene++/lucene++-3.0.6.ebuild
new file mode 100644
index 000000000000..b45dc6e6fef2
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/lucene++/lucene++-3.0.6.ebuild,v 1.1 2015/01/10 13:37:49 johu Exp $
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Java Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-demos.patch"
+ "${FILESDIR}/${P}-disable-tests.patch"
+ "${FILESDIR}/${P}-fix-installing-headers.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_DESTINATION=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/lucene++/metadata.xml b/dev-cpp/lucene++/metadata.xml
new file mode 100644
index 000000000000..06ee9b592b0b
--- /dev/null
+++ b/dev-cpp/lucene++/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">luceneplusplus/luceneplusplus</remote-id>
+ </upstream>
+</pkgmetadata>
+