summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 03:35:15 +0000
commit9d54ef8c61839b12b04e3f719f44822578952d2b (patch)
tree42e96e1d4a6c36d7019ce455f02128719347fc90 /dev-cpp
parentfix license/repoman (diff)
downloadgentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.gz
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.tar.bz2
gentoo-2-9d54ef8c61839b12b04e3f719f44822578952d2b.zip
fix license/repoman
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild8
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.2.3.ebuild17
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.2.5.ebuild16
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild5
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild5
5 files changed, 19 insertions, 32 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild b/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
index 01d5880fd168..00c2640966cc 100644
--- a/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild,v 1.3 2003/08/01 20:49:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild,v 1.4 2003/08/07 03:35:15 vapier Exp $
+
+inherit eutils
DESCRIPTION="C++ interface for GTK+"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
SRC_URI="http://download.sourceforge.net/gtkmm/${P}.tar.gz"
# ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz
# http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz"
-HOMEPAGE="http://gtkmm.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1.2"
@@ -22,7 +24,7 @@ src_unpack() {
# this patch applies only to gtkmm-1.2.9. gtkmm has been fixed
# in CVS. It fixes a build problem with gcc3.1.
# (http://marc.theaimsgroup.com/?l=gtkmm&m=101879848701486&w=2)
- patch -p0 <${FILESDIR}/gtkmm-1.2.9-gcc3.1-gentoo.patch
+ epatch ${FILESDIR}/gtkmm-1.2.9-gcc3.1-gentoo.patch
}
src_compile() {
diff --git a/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild b/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
index 81af917fdd9e..d9a4738789ca 100644
--- a/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
@@ -1,29 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild,v 1.2 2003/07/23 21:09:39 gmsoft Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild,v 1.3 2003/08/07 03:35:15 vapier Exp $
inherit gnome2
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="C++ interface for GTK+2"
HOMEPAGE="http://gtkmm.sourceforge.net/"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ~ppc ~sparc hppa"
+LICENSE="LGPL-2.1"
SLOT="2"
+KEYWORDS="x86 ~ppc ~sparc hppa"
RDEPEND=">=dev-libs/glib-2.2
>=x11-libs/gtk+-2.2
>=dev-libs/libsigc++-1.2
!=sys-devel/gcc-3.3.0*"
-
DEPEND="${RDEPEND}
>=dev-lang/perl-5.6.0
dev-util/pkgconfig"
-DOCS="AUTHORS CHANGES COPYING ChangeLog HACKING PORTING NEWS README TODO"
-
-
-
-
+DOCS="AUTHORS CHANGES ChangeLog HACKING PORTING NEWS README TODO"
diff --git a/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild b/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
index 6e06d1e070ef..e1fe947b8d45 100644
--- a/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
@@ -1,26 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild,v 1.1 2003/07/25 15:52:16 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild,v 1.2 2003/08/07 03:35:15 vapier Exp $
inherit gnome2
-IUSE=""
DESCRIPTION="C++ interface for GTK+2"
HOMEPAGE="http://gtkmm.sourceforge.net/"
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="LGPL-2.1"
SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc"
RDEPEND=">=dev-libs/glib-2.2
>=x11-libs/gtk+-2.2
>=dev-libs/libsigc++-1.2"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-DOCS="AUTHORS CHANGES COPYING ChangeLog HACKING PORTING NEWS README TODO"
-
-
-
-
+DOCS="AUTHORS CHANGES ChangeLog HACKING PORTING NEWS README TODO"
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
index 4c59ae7b0295..b000f394c6fb 100644
--- a/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild,v 1.2 2003/07/11 20:49:57 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild,v 1.3 2003/08/07 03:34:05 vapier Exp $
MY_P=${P/pp/++}
DESCRIPTION="C++ wrapper for the libxml XML parser library"
@@ -10,7 +10,6 @@ SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
-IUSE=""
DEPEND=">=dev-libs/libxml2-2.5.1"
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
index 2b39a24e13aa..72ec879c9d38 100644
--- a/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild,v 1.1 2003/06/19 00:41:50 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild,v 1.2 2003/08/07 03:34:05 vapier Exp $
MY_P=${P/pp/++}
DESCRIPTION="C++ wrapper for the libxml XML parser library"
@@ -10,7 +10,6 @@ SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
-IUSE=""
DEPEND=">=dev-libs/libxml2-2.5.1"