summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-13 13:30:11 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-13 13:30:11 +0000
commite856bf005978847a2766f0247b3137cab2187dd0 (patch)
tree22c3eae96f8f55cfd7910b6968bbbafc6dd3cbea /dev-cpp
parentDelete older ebuild. (diff)
downloadgentoo-2-e856bf005978847a2766f0247b3137cab2187dd0.tar.gz
gentoo-2-e856bf005978847a2766f0247b3137cab2187dd0.tar.bz2
gentoo-2-e856bf005978847a2766f0247b3137cab2187dd0.zip
Version bump with multiple bugfixes and solving warnings caused by broken cairommconfig.h (bug #331405 by David King). Remove old.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cairomm/ChangeLog9
-rw-r--r--dev-cpp/cairomm/cairomm-1.4.4.ebuild42
-rw-r--r--dev-cpp/cairomm/cairomm-1.8.6.ebuild (renamed from dev-cpp/cairomm/cairomm-1.6.0.ebuild)30
3 files changed, 24 insertions, 57 deletions
diff --git a/dev-cpp/cairomm/ChangeLog b/dev-cpp/cairomm/ChangeLog
index 0daae86d7b9c..aecaf63dd9b7 100644
--- a/dev-cpp/cairomm/ChangeLog
+++ b/dev-cpp/cairomm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/cairomm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.44 2011/01/22 07:31:58 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.45 2011/02/13 13:30:11 pacho Exp $
+
+*cairomm-1.8.6 (13 Feb 2011)
+
+ 13 Feb 2011; Pacho Ramos <pacho@gentoo.org> -cairomm-1.4.4.ebuild,
+ -cairomm-1.6.0.ebuild, +cairomm-1.8.6.ebuild:
+ Version bump with multiple bugfixes and solving warnings caused by broken
+ cairommconfig.h (bug #331405 by David King). Remove old.
*cairomm-1.9.8 (22 Jan 2011)
diff --git a/dev-cpp/cairomm/cairomm-1.4.4.ebuild b/dev-cpp/cairomm/cairomm-1.4.4.ebuild
deleted file mode 100644
index 2407d2b80710..000000000000
--- a/dev-cpp/cairomm/cairomm-1.4.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.4.4.ebuild,v 1.10 2009/10/12 20:08:39 eva Exp $
-
-inherit eutils
-
-DESCRIPTION="C++ bindings for the Cairo vector graphics library"
-HOMEPAGE="http://cairographics.org/cairomm"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND=">=x11-libs/cairo-1.4.0"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use examples; then
- # don't waste time building the examples
- sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
- die "sed Makefile.in failed"
- fi
-}
-
-src_compile() {
- econf $(use_enable doc docs) || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use examples; then
- cp -R examples "${D}"/usr/share/doc/${PF}
- fi
-}
diff --git a/dev-cpp/cairomm/cairomm-1.6.0.ebuild b/dev-cpp/cairomm/cairomm-1.8.6.ebuild
index 89b2bfc35ac5..b5eaeeafc1cb 100644
--- a/dev-cpp/cairomm/cairomm-1.6.0.ebuild
+++ b/dev-cpp/cairomm/cairomm-1.8.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.6.0.ebuild,v 1.10 2009/04/10 14:00:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.8.6.ebuild,v 1.1 2011/02/13 13:30:11 pacho Exp $
+
+EAPI="3"
inherit eutils
@@ -10,17 +12,16 @@ SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc svg"
-RDEPEND=">=x11-libs/cairo-1.5.14"
+# FIXME: svg support is automagic
+RDEPEND=">=x11-libs/cairo-1.8[svg?]
+ dev-libs/libsigc++:2"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+ doc? ( app-doc/doxygen )"
+src_prepare() {
# don't waste time building examples because they are marked as "noinst"
sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
@@ -29,12 +30,13 @@ src_unpack() {
sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
}
-src_compile() {
- econf $(use_enable doc docs) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf \
+ --disable-tests \
+ $(use_enable doc documentation)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README ChangeLog
+ dodoc NEWS README ChangeLog || die "dodoc failed"
}