summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 16:43:00 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 16:43:00 +0000
commit511393fb69b0db923195ada866f6272eeb635d35 (patch)
treecda232dcda8ac24acb6b9266f3d4fb64132da0eb /dev-db/gmyclient/gmyclient-0.3.ebuild
parentadded ppc to keywords (diff)
downloadgentoo-2-511393fb69b0db923195ada866f6272eeb635d35.tar.gz
gentoo-2-511393fb69b0db923195ada866f6272eeb635d35.tar.bz2
gentoo-2-511393fb69b0db923195ada866f6272eeb635d35.zip
Changed econf||die to econf
Diffstat (limited to 'dev-db/gmyclient/gmyclient-0.3.ebuild')
-rw-r--r--dev-db/gmyclient/gmyclient-0.3.ebuild27
1 files changed, 6 insertions, 21 deletions
diff --git a/dev-db/gmyclient/gmyclient-0.3.ebuild b/dev-db/gmyclient/gmyclient-0.3.ebuild
index 38469d83d381..2e0ff1e40aaf 100644
--- a/dev-db/gmyclient/gmyclient-0.3.ebuild
+++ b/dev-db/gmyclient/gmyclient-0.3.ebuild
@@ -1,41 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gmyclient/gmyclient-0.3.ebuild,v 1.1 2002/11/05 14:19:42 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gmyclient/gmyclient-0.3.ebuild,v 1.2 2002/12/18 16:43:00 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Gnome based mysql client"
SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
-HOMEPAGE="http://gmyclient.sourceforge.net"
+HOMEPAGE="http://gmyclient.sourceforge.net/"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc"
+IUSE="nls"
DEPEND="( >=gnome-base/gnome-libs-1.2*
dev-db/mysql )"
-
RDEPEND="( >=gnome-base/gnome-libs-1.2* )"
src_compile() {
- local myconf
-
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- econf $myconf || die
-
+ econf `use_enable nls`
emake || die
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
-
+ einstall
dodoc AUTHORS COPYING ChangeLog NEWS README TODO
}
-
-